summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-06-01 21:14:58 +0200
committerJohannes Huber <johu@gentoo.org>2016-06-01 21:15:10 +0200
commit8bfde08d22c3e55127883857d4ac46bbe4efa164 (patch)
treef0600af6ef0def372270519f8a0e16de7ba6edd6
parentdev-libs/boost-numpy: drop obsolete snapshot ebuild (diff)
downloadgentoo-8bfde08d22c3e55127883857d4ac46bbe4efa164.tar.gz
gentoo-8bfde08d22c3e55127883857d4ac46bbe4efa164.tar.bz2
gentoo-8bfde08d22c3e55127883857d4ac46bbe4efa164.zip
media-sound/amarok: Fix build w/ gcc-6
By adding upstreamed patch from opensuse. Gentoo-bug: 584682 Package-Manager: portage-2.3.0_rc1
-rw-r--r--media-sound/amarok/amarok-2.8.90-r2.ebuild1
-rw-r--r--media-sound/amarok/files/amarok-2.8.90-gcc6.patch36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/amarok/amarok-2.8.90-r2.ebuild b/media-sound/amarok/amarok-2.8.90-r2.ebuild
index 04e5ff614a0f..03a5e1204f97 100644
--- a/media-sound/amarok/amarok-2.8.90-r2.ebuild
+++ b/media-sound/amarok/amarok-2.8.90-r2.ebuild
@@ -77,6 +77,7 @@ PATCHES=(
"${FILESDIR}/${P}-mysql-embedded.patch"
"${FILESDIR}/${P}-mysqld-rpath.patch"
"${FILESDIR}/${P}-scriptconsole.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
)
src_configure() {
diff --git a/media-sound/amarok/files/amarok-2.8.90-gcc6.patch b/media-sound/amarok/files/amarok-2.8.90-gcc6.patch
new file mode 100644
index 000000000000..bad936a6645a
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.90-gcc6.patch
@@ -0,0 +1,36 @@
+From 9308403e1c8484052f277bf6de32ee07c93a4beb Mon Sep 17 00:00:00 2001
+From: Rex Dieter <rdieter@math.unl.edu>
+Date: Wed, 1 Jun 2016 13:58:26 -0500
+Subject: [PATCH] gcc6 buildfix
+
+courtesy of opensuse, thx
+
+BUG: 363054
+---
+ src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp b/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp
+index 4bdb9b9..e327354 100644
+--- a/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp
++++ b/src/core-impl/playlists/types/file/xspf/XSPFPlaylist.cpp
+@@ -28,6 +28,7 @@
+ #include "playlist/PlaylistModelStack.h"
+
+ using namespace Playlists;
++using namespace Playlist;
+
+ XSPFPlaylist::XSPFPlaylist( const KUrl &url, Playlists::PlaylistProvider *provider, OnLoadAction onLoad )
+ : PlaylistFile( url, provider )
+@@ -101,7 +102,7 @@ XSPFPlaylist::load()
+ //FIXME: this needs to be moved to whatever is creating the XSPFPlaylist
+ if( m_autoAppendAfterLoad )
+ The::playlistController()->insertPlaylist(
+- ::Playlist::ModelStack::instance()->bottom()->rowCount(),
++ ModelStack::instance()->bottom()->rowCount(),
+ Playlists::PlaylistPtr( this )
+ );
+ }
+--
+2.8.3
+