summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-29 08:46:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-29 08:47:14 +0200
commit8da8156d73a42697931f4ae3429212d2370100ca (patch)
treee308e52143e7a77fbe086f740fc88f8b938ae6c4
parentdev-lang/nasm: bump up to 2.15.01 (diff)
downloadgentoo-8da8156d73a42697931f4ae3429212d2370100ca.tar.gz
gentoo-8da8156d73a42697931f4ae3429212d2370100ca.tar.bz2
gentoo-8da8156d73a42697931f4ae3429212d2370100ca.zip
media-libs/libcddb: Fixed build with CONFIG_SHELL != bash
Switched to EAPI-7 Closes: https://bugs.gentoo.org/528012 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-libs/libcddb/libcddb-1.3.2-r1.ebuild43
1 files changed, 28 insertions, 15 deletions
diff --git a/media-libs/libcddb/libcddb-1.3.2-r1.ebuild b/media-libs/libcddb/libcddb-1.3.2-r1.ebuild
index 06c26b854504..527e22390ba0 100644
--- a/media-libs/libcddb/libcddb-1.3.2-r1.ebuild
+++ b/media-libs/libcddb/libcddb-1.3.2-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
-
-inherit autotools-multilib
+inherit autotools multilib-minimal
DESCRIPTION="A library for accessing a CDDB server"
HOMEPAGE="http://libcddb.sourceforge.net/"
@@ -17,7 +15,8 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-lin
IUSE="doc static-libs"
RDEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]"
-DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="${DEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
RESTRICT="test"
@@ -25,22 +24,36 @@ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
MULTILIB_WRAPPED_HEADERS=( /usr/include/cddb/version.h )
-src_configure() {
- local myeconfargs=( --without-cdio )
- autotools-multilib_src_configure
+src_prepare() {
+ default
+ # Required for CONFIG_SHELL != bash (bug #528012)
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --without-cdio
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
-src_compile() {
- autotools-multilib_src_compile
+multilib_src_compile() {
+ default
- if use doc; then
- cd "${S}"/doc
+ if use doc ; then
+ cd "${S}"/doc || die
doxygen doxygen.conf || die
fi
}
-src_install() {
- autotools-multilib_src_install
+multilib_src_install_all() {
+ default
- use doc && dohtml "${S}"/doc/html/*
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ if use doc ; then
+ docinto html
+ dodoc "${S}"/doc/html/*
+ fi
}