summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather Cynede <cynede@gentoo.org>2015-08-12 18:02:25 +0400
committerHeather Cynede <cynede@gentoo.org>2015-08-12 18:02:25 +0400
commit8da86ec4c66027c014f8fa59b33989ce65268317 (patch)
tree9ff30bad66a9f9860fdc0dfcde40196d2ca76ef8
parentdev-lang/mono bump to 4.0.3.20 (diff)
downloadgentoo-8da86ec4c66027c014f8fa59b33989ce65268317.tar.gz
gentoo-8da86ec4c66027c014f8fa59b33989ce65268317.tar.bz2
gentoo-8da86ec4c66027c014f8fa59b33989ce65268317.zip
dev-lang/mono add recent mono 3 version
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-3.12.1.ebuild2
-rw-r--r--dev-lang/mono/mono-3.2.3.ebuild119
3 files changed, 1 insertions, 121 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index af6730b7468a..775a441e2d6b 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -1,3 +1,2 @@
DIST mono-3.12.1.tar.bz2 73487974 SHA256 5d8cf153af2948c06bc9fbf5088f6834868e4db8e5f41c7cff76da173732b60d SHA512 7ff87d95c347186347dc7a9ffb767112717de2b808f8f1b612c56c9eb70fdcc0c8f586989be44444509a2768e71854d8195567196c992cc2c5b184ecbe5ac190 WHIRLPOOL fe3a6cdb8bf4602ad1d1e43099b2a552005c315a232a7d2bddf0081a68e882228712af5301f18d3a890f454041c4a34d6f0926aaba34401ecfa702eecd9415c8
-DIST mono-3.2.3.tar.bz2 81810387 SHA256 b8c2f97d6a5232dbf5a8180e5c38d4722b81af748893649d7d9e82c5cf8ef41a SHA512 a40a03d09ce07d7f8c25ef872835f6f29458e02aa386e4097b2cffd918d3bece1205bb42beb51a1384eba884e4c6f9b6505421babf337ec64f670c7f90c6262d WHIRLPOOL 9781dd387ce57a54ae84c91b6bfc346c4607daa3738746db0f41515dfc6c0b271b6e7d2ec828f75dc6953d15fd965cd3ef1d88fe5925c6dc8019cc9d188d6982
DIST mono-4.0.3.20.tar.bz2 95987018 SHA256 976c0be3ab9b66361f48e8133c60b1b2942b88c44a7a11a19cd98f5ff64313fc SHA512 bbf65abb4d91aa65fd467a59dcc7c290f779ab9f8df9d82b56957893556ad8d13dc3cc85f3128145e0dd15aaa8b0ea872c4b66af4fd211243d368514f10a07cd WHIRLPOOL 9e7730c234dbf34a81637789a3ffee4ce37a1eaef6748f28a79875411d3c1d97cfbdce6146abfa7dde245e821fe52b2766bb7240637a8b8272788dffc5fd21ae
diff --git a/dev-lang/mono/mono-3.12.1.ebuild b/dev-lang/mono/mono-3.12.1.ebuild
index 03928d106f7d..1952ade7f2f4 100644
--- a/dev-lang/mono/mono-3.12.1.ebuild
+++ b/dev-lang/mono/mono-3.12.1.ebuild
@@ -35,7 +35,7 @@ DEPEND="${COMMONDEPEND}
pkg_pretend() {
# If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
# See http://bugs.gentoo.org/261869 for more info."
- CONFIG_CHECK="~SYSVIPC"
+ CONFIG_CHECK="SYSVIPC"
use kernel_linux && check_extra_config
}
diff --git a/dev-lang/mono/mono-3.2.3.ebuild b/dev-lang/mono/mono-3.2.3.ebuild
deleted file mode 100644
index 462e3ab5de6b..000000000000
--- a/dev-lang/mono/mono-3.2.3.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
-
-inherit eutils linux-info mono-env flag-o-matic pax-utils autotools-utils
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.mono-project.com/Main_Page"
-SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-
-IUSE="nls minimal pax_kernel xen doc debug"
-
-COMMONDEPEND="
- !dev-util/monodoc
- !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
- ia64? ( sys-libs/libunwind )
- nls? ( sys-devel/gettext )
-"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )
-"
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- virtual/yacc
- pax_kernel? ( sys-apps/elfix )
-"
-
-pkg_pretend() {
- # If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
- # See http://bugs.gentoo.org/261869 for more info."
- CONFIG_CHECK="~SYSVIPC"
- use kernel_linux && check_extra_config
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- mono-env_pkg_setup
-}
-
-src_prepare() {
- # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTEC is enable. #286280
- # RANDMMAP kill the build proces to #347365
- if use pax_kernel ; then
- ewarn "We are disabling MPROTECT on the mono binary."
-
- # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxctl-ng -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
- fi
-
- # mono build system can fail otherwise
- strip-flags
-
- # Remove this at your own peril. Mono will barf in unexpected ways.
- append-flags -fno-strict-aliasing
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- # NOTE: We need the static libs for now so mono-debugger works.
- # See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
- #
- # --without-moonlight since www-plugins/moonlight is not the only one
- # using mono: https://bugzilla.novell.com/show_bug.cgi?id=641005#c3
- #
- # --with-profile4 needs to be always enabled since it's used by default
- # and, otherwise, problems like bug #340641 appear.
- #
- # sgen fails on ppc, bug #359515
- local myeconfargs=(
- --enable-system-aot=yes
- --enable-static
- --disable-quiet-build
- --without-moonlight
- --with-libgdiplus=$(usex minimal no installed)
- $(use_with xen xen_opt)
- --without-ikvm-native
- --with-jit
- --disable-dtrace
- --with-profile4
- --with-sgen=$(usex ppc no yes)
- $(use_with doc mcs-docs)
- $(use_enable debug)
- $(use_enable nls)
- )
-
- autotools-utils_src_configure
-}
-
-src_compile() {
- nonfatal autotools-utils_src_compile || {
- eqawarn "maintainer of this ebuild has no idea why it fails. If you happen to know how to fix it - please let me know"
- autotools-utils_src_compile
- }
-}
-
-src_test() {
- cd mcs/tests || die
- emake check
-}
-
-src_install() {
- autotools-utils_src_install
-
- # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
- # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
- # for reference.
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
-}