summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:15:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-29 09:18:08 +0100
commit8f089e5a8dee8999719cb7a0fb564f8d7158793d (patch)
tree3322837fc627e5c725a349a5745874f792ec6d6b
parentapp-emulation/firecracker: Ignore all flags (diff)
downloadgentoo-8f089e5a8dee8999719cb7a0fb564f8d7158793d.tar.gz
gentoo-8f089e5a8dee8999719cb7a0fb564f8d7158793d.tar.bz2
gentoo-8f089e5a8dee8999719cb7a0fb564f8d7158793d.zip
dev-haskell/dictionary-sharing: new pachage, a depend of testing-feat-1.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/dictionary-sharing/Manifest1
-rw-r--r--dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild31
-rw-r--r--dev-haskell/dictionary-sharing/metadata.xml8
-rw-r--r--dev-haskell/testing-feat/Manifest1
-rw-r--r--dev-haskell/testing-feat/testing-feat-1.1.0.0.ebuild28
5 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/dictionary-sharing/Manifest b/dev-haskell/dictionary-sharing/Manifest
new file mode 100644
index 000000000000..8ee7eef9198c
--- /dev/null
+++ b/dev-haskell/dictionary-sharing/Manifest
@@ -0,0 +1 @@
+DIST dictionary-sharing-0.1.0.0.tar.gz 2524 BLAKE2B d8a5a942749add31b4622b8bcea9784273fde2cb87865f5d7103f06f2fe9dbd82f247101b235ed7b716a8fb5e3dc813e897776778ee377442685d2b7d08d37b8 SHA512 5af84caae1339ddb006ba77f2505da63e0977368f93f4d84dbd8f31c0e45cea988a9175b5273cc2280b8d8f44dd8c921385ea2c38b239f08a565cae7c1fd6415
diff --git a/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild b/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild
new file mode 100644
index 000000000000..ea60ad0ba50c
--- /dev/null
+++ b/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Sharing/memoization of class members"
+HOMEPAGE="http://hackage.haskell.org/package/dictionary-sharing"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+src_prepare() {
+ default
+
+ #https://hackage.haskell.org/package/dictionary-sharing-0.1.0.0/revisions/
+ cabal_chdeps \
+ 'containers >=0.5 && <0.6' 'containers >= 0.5'
+}
diff --git a/dev-haskell/dictionary-sharing/metadata.xml b/dev-haskell/dictionary-sharing/metadata.xml
new file mode 100644
index 000000000000..b7878815d80d
--- /dev/null
+++ b/dev-haskell/dictionary-sharing/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/testing-feat/Manifest b/dev-haskell/testing-feat/Manifest
index 79cc2777616e..258c90b61a82 100644
--- a/dev-haskell/testing-feat/Manifest
+++ b/dev-haskell/testing-feat/Manifest
@@ -1 +1,2 @@
DIST testing-feat-0.4.0.3.tar.gz 17864 BLAKE2B ff57b181e3ed34a5e9794b9c3830122e2bd36a8199a641e2025cd5a2e467dae15cfc5d9cb4e21f198cdb667d7b9b6a5f88850f68c69d00da016200c5a12c33ce SHA512 0dabd9129472d9cf91b87a31aec9265369cdf58ec47fe74997df08097d4e93edb4f4bf52050bbca0c345e5993c12d0fcf755b94dd80093a33ba8fef366b08516
+DIST testing-feat-1.1.0.0.tar.gz 15291 BLAKE2B e590af9bbe5b5382bdefb4375cff05340e9be2bfa75e7dde895dee7bf1a84e8494f304306a979c8120b98c5fe9899d9ad8d271456e6318b5a78b1381306d4838 SHA512 b6480e990f9b8065d9f5e9fcf0dfeefe7e722830848ed5614cbe11581329f4341eb90547b67c1471d8b2e8b230490040714b1f560456797980c5cec9d0aef6e0
diff --git a/dev-haskell/testing-feat/testing-feat-1.1.0.0.ebuild b/dev-haskell/testing-feat/testing-feat-1.1.0.0.ebuild
new file mode 100644
index 000000000000..b49fdd83ecf5
--- /dev/null
+++ b/dev-haskell/testing-feat/testing-feat-1.1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Functional Enumeration of Algebraic Types"
+HOMEPAGE="https://github.com/JonasDuregard/testing-feat"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">dev-haskell/quickcheck-2:2=[profile?] <dev-haskell/quickcheck-3:2=[profile?]
+ <dev-haskell/semigroups-0.19:=[profile?]
+ <dev-haskell/size-based-0.2:=[profile?]
+ <dev-haskell/testing-type-modifiers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"