summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-17 10:10:31 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-17 11:04:30 +0200
commit901932cf93b80a4d498de4fb9bcc6b8aac6bbdfe (patch)
tree2eff0260008789e70809e4b327411c8ef877a238
parentmedia-gfx/pngcrush: Removed old. (diff)
downloadgentoo-901932cf93b80a4d498de4fb9bcc6b8aac6bbdfe.tar.gz
gentoo-901932cf93b80a4d498de4fb9bcc6b8aac6bbdfe.tar.bz2
gentoo-901932cf93b80a4d498de4fb9bcc6b8aac6bbdfe.zip
media-libs/gexiv2: Bump to version 0.10.4
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-libs/gexiv2/Manifest1
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index e6b9f4dfc2b5..d32ffd10941e 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,2 +1,3 @@
DIST gexiv2-0.10.2.tar.xz 242704 SHA256 2fd21f0ed5125e51d02226e7f41be751cfa8ae411a8ed1a651e16b06d79047b2 SHA512 4f2f666b0dc1beb730dbd791dc690bebd8acefbc32a5e2d22fc72a4e2d839d3965b5367134c79c6076507713369193d5fb3e6d0fad984d53e53d57a20e41deab WHIRLPOOL d29a2e13ab12ce7f78ec664ce08f10efb70ce38bae6c8eb4061b16925c6eb498265ceb936eeef35788ea7ac5dc8fd98ddd873dcbd686ceb38f6bd1ebd571810f
DIST gexiv2-0.10.3.tar.xz 244816 SHA256 390cfb966197fa9f3f32200bc578d7c7f3560358c235e6419657206a362d3988 SHA512 a258a95e3e9dddc6636430d8a2bc222b6605e5d0d122ea1b951f97568cecd04b2d3cbc522625918faf3b5a3e670b01db81a45c2c5c5d65e6eb4b4f4a2ac69e8f WHIRLPOOL e50401f642a2252cad664716004038fdd364e9a42b93c7b9748e0f93b652cad31432f7f58571dd0ff67c8dcb1deca590eaaf42ad287d8d27110d0626a352154b
+DIST gexiv2-0.10.4.tar.xz 267800 SHA256 ad8d31afdc0a1932cc44c4cfcea449497c0d0b445c0ad2f9735707b306e71ca4 SHA512 90f864f47ff6c1580579c3497580b398bb8d4ab9b56488017ae92d778a931bceddb8eb6fdc6dc7451d6205187c734b87e2bf395b86cddfb9022f6423b3390d8f WHIRLPOOL 3f78ddf56e2b9eb96e903051a4f36ac030181686767eb3dc89dd22296855d92c0a799fb174d7b82ec89e083afcb24cc3904ee0db9dbd66436a5f12b8242fb897
diff --git a/media-libs/gexiv2/gexiv2-0.10.4.ebuild b/media-libs/gexiv2/gexiv2-0.10.4.ebuild
new file mode 100644
index 000000000000..7b686e5299f0
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator xdg-utils
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="introspection python static-libs"
+
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ xdg_environment_reset
+ tc-export CXX
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}