summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-03 15:39:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-03 15:39:28 -0500
commit92e9bfcd6246ad11362eba82cc8318032b3589de (patch)
tree22bf813d555c9042ea91aa60718ce007cbf055c8
parentapp-admin/ansible: switch to DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-92e9bfcd6246ad11362eba82cc8318032b3589de.tar.gz
gentoo-92e9bfcd6246ad11362eba82cc8318032b3589de.tar.bz2
gentoo-92e9bfcd6246ad11362eba82cc8318032b3589de.zip
app-admin/ansible: 2.9.13 stable amd64/x86 with cleanup
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.12.ebuild69
-rw-r--r--app-admin/ansible/ansible-2.9.13.ebuild2
3 files changed, 1 insertions, 71 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 547a03e7134d..afeaf6678c42 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,2 @@
DIST ansible-2.10.0.tar.gz 25454980 BLAKE2B 91f930518b90b36aa2c21f553092233059fada86fd1674c9c6e881484b1bd4e68a3eaa05d82e15115906e55da99c43394c3de36a898e26bb222f780b82f8a5bd SHA512 878036f06e1705e4392223bda210b2acae0232069d0cec02a47f13f6b3bc6c9538fb515a2d2dc6003695bcf0915fdd3dfc5b8dc59355e37e2ca8fa48bbd79657
-DIST ansible-2.9.12.tar.gz 14260349 BLAKE2B 6d7fdc82489df755196b890b39c166e9639c94e4238b4bf33686a3ab17fcc92c6b3a05f80e1276795b966aaa318ec7d9003099950102c014adb1a5d730928633 SHA512 6c05c49e363d4d68516dfea448cead3e2c281d1288c9467a0b6dd083504f303df694ed1c5957ae6582b28acc937d12d13333254328e13bac430b9b7fa4354f23
DIST ansible-2.9.13.tar.gz 14261322 BLAKE2B 5de939a99cd703eaf240f536a9a4b707e3931364647782dde2bbebd5b755253594cbb1cf8c4e9f22a14fca85c9f018ee6ea26bce1cbe2145ba72e5f5ec313670 SHA512 cb08adf62df0f3650425a5d960baadd7439c7c1e95b8f9df3d08e7504f9622b9e5f7104b8700b0f1e9fe318d349a6a5728e9178f0193fb4a190456e30a2f1eb2
diff --git a/app-admin/ansible/ansible-2.9.12.ebuild b/app-admin/ansible/ansible-2.9.12.ebuild
deleted file mode 100644
index 9d495e30b009..000000000000
--- a/app-admin/ansible/ansible-2.9.12.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !app-admin/ansible-base
-"
-DEPEND="
- !app-admin/ansible-base
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}
diff --git a/app-admin/ansible/ansible-2.9.13.ebuild b/app-admin/ansible/ansible-2.9.13.ebuild
index 5641f4825a3c..9d495e30b009 100644
--- a/app-admin/ansible/ansible-2.9.13.ebuild
+++ b/app-admin/ansible/ansible-2.9.13.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
IUSE="doc test"
RESTRICT="test"