summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-24 14:47:22 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-25 06:41:44 +0100
commit930a7a4c2d007619bc4a0347b951b82379d822af (patch)
tree2a5d7df235f4ac679ce338663e5bfdff43795650
parentapp-admin/syslog-ng: Stable for PPC64 (bug #563638). (diff)
downloadgentoo-930a7a4c2d007619bc4a0347b951b82379d822af.tar.gz
gentoo-930a7a4c2d007619bc4a0347b951b82379d822af.tar.bz2
gentoo-930a7a4c2d007619bc4a0347b951b82379d822af.zip
dev-ruby/listen: make sure only one slot installs in bin
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-ruby/listen/listen-2.8.6-r1.ebuild40
-rw-r--r--dev-ruby/listen/listen-3.0.3.ebuild2
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/listen/listen-2.8.6-r1.ebuild b/dev-ruby/listen/listen-2.8.6-r1.ebuild
new file mode 100644
index 000000000000..3a83aaf47be7
--- /dev/null
+++ b/dev-ruby/listen/listen-2.8.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Listens to file modifications and notifies you about the changes"
+HOMEPAGE="https://github.com/guard/listen"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on other packages trying to install a /usr/bin/listen
+RDEPEND+="!!media-sound/listen !!media-radio/ax25"
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0
+ >=dev-ruby/celluloid-0.15.2"
+ruby_add_bdepend "test? ( dev-ruby/celluloid-io )"
+
+all_ruby_prepare() {
+ sed -i -e "/git/,+3d" -e "/rb-fsevent/d" -e "/bundler/d" -e "/rspec-retry/d" ${PN}.gemspec || die
+ sed -i -e "/retry/d" spec/spec_helper.rb || die
+ rm -rf spec/lib/listen/adapter/darwin_spec.rb || die
+}
diff --git a/dev-ruby/listen/listen-3.0.3.ebuild b/dev-ruby/listen/listen-3.0.3.ebuild
index 524cd1dcec88..7e1ab806d052 100644
--- a/dev-ruby/listen/listen-3.0.3.ebuild
+++ b/dev-ruby/listen/listen-3.0.3.ebuild
@@ -25,7 +25,7 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solari
IUSE="test"
# Block on other packages trying to install a /usr/bin/listen
-RDEPEND+="!!media-sound/listen !!media-radio/ax25"
+RDEPEND+="!!media-sound/listen !!media-radio/ax25 !!<dev-ruby/listen-2.8.6:2"
ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"