summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-04-23 22:09:48 -0400
committerDavid Seifert <soap@gentoo.org>2017-04-24 11:11:59 +0200
commit93997c2c947e4b5e4e34021c9596e467ca37166a (patch)
tree2830c38579860b6e175dbd73682692880b71687d
parentmedia-tv/kodi: USE="opengl" or "gles" require USE="X" (diff)
downloadgentoo-93997c2c947e4b5e4e34021c9596e467ca37166a.tar.gz
gentoo-93997c2c947e4b5e4e34021c9596e467ca37166a.tar.bz2
gentoo-93997c2c947e4b5e4e34021c9596e467ca37166a.zip
media-tv/kodi: Remove the "ssl" USE flag; upstream doesn't support building without ssl
Gentoo-bug: 615386 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4487
-rw-r--r--media-tv/kodi/kodi-17.0-r4.ebuild (renamed from media-tv/kodi/kodi-17.0-r3.ebuild)10
-rw-r--r--media-tv/kodi/kodi-17.1-r3.ebuild (renamed from media-tv/kodi/kodi-17.1-r2.ebuild)10
-rw-r--r--media-tv/kodi/kodi-9999.ebuild10
3 files changed, 12 insertions, 18 deletions
diff --git a/media-tv/kodi/kodi-17.0-r3.ebuild b/media-tv/kodi/kodi-17.0-r4.ebuild
index 98e105edaf89..719b9853100e 100644
--- a/media-tv/kodi/kodi-17.0-r3.ebuild
+++ b/media-tv/kodi/kodi-17.0-r4.ebuild
@@ -27,7 +27,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gles libressl libusb lirc mysql nfs nonfree +opengl +ssl pulseaudio samba sftp systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gles libressl libusb lirc mysql nfs nonfree +opengl pulseaudio samba sftp systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau webserver +X +xslt zeroconf"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( gles opengl )
@@ -74,10 +74,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.51.0
nfs? ( net-fs/libnfs:= )
opengl? ( media-libs/glu )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.2j:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ !libressl? ( >=dev-libs/openssl-1.0.2j:0= )
+ libressl? ( dev-libs/libressl:0= )
pulseaudio? ( media-sound/pulseaudio )
samba? ( >=net-fs/samba-3.4.6[smbclient(+)] )
sftp? ( net-libs/libssh[sftp] )
@@ -226,7 +224,7 @@ src_configure() {
-DENABLE_NONFREE=$(usex nonfree)
-DENABLE_OPENGLES=$(usex gles)
-DENABLE_OPENGL=$(usex opengl)
- -DENABLE_OPENSSL=$(usex ssl)
+ -DENABLE_OPENSSL=ON
-DENABLE_OPTICAL=$(usex dvd)
-DENABLE_PLIST=$(usex airplay)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
diff --git a/media-tv/kodi/kodi-17.1-r2.ebuild b/media-tv/kodi/kodi-17.1-r3.ebuild
index 98e105edaf89..719b9853100e 100644
--- a/media-tv/kodi/kodi-17.1-r2.ebuild
+++ b/media-tv/kodi/kodi-17.1-r3.ebuild
@@ -27,7 +27,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gles libressl libusb lirc mysql nfs nonfree +opengl +ssl pulseaudio samba sftp systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gles libressl libusb lirc mysql nfs nonfree +opengl pulseaudio samba sftp systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau webserver +X +xslt zeroconf"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( gles opengl )
@@ -74,10 +74,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.51.0
nfs? ( net-fs/libnfs:= )
opengl? ( media-libs/glu )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.2j:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ !libressl? ( >=dev-libs/openssl-1.0.2j:0= )
+ libressl? ( dev-libs/libressl:0= )
pulseaudio? ( media-sound/pulseaudio )
samba? ( >=net-fs/samba-3.4.6[smbclient(+)] )
sftp? ( net-libs/libssh[sftp] )
@@ -226,7 +224,7 @@ src_configure() {
-DENABLE_NONFREE=$(usex nonfree)
-DENABLE_OPENGLES=$(usex gles)
-DENABLE_OPENGL=$(usex opengl)
- -DENABLE_OPENSSL=$(usex ssl)
+ -DENABLE_OPENSSL=ON
-DENABLE_OPTICAL=$(usex dvd)
-DENABLE_PLIST=$(usex airplay)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index fedde8f344a6..0e7f4c90da4f 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -27,7 +27,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gles libressl libusb lirc mysql nfs nonfree +opengl +ssl pulseaudio samba sftp systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dbus debug dvd gles libressl libusb lirc mysql nfs nonfree +opengl pulseaudio samba sftp systemd +system-ffmpeg test +udev udisks upnp upower vaapi vdpau webserver +X +xslt zeroconf"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( gles opengl )
@@ -74,10 +74,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=net-misc/curl-7.51.0
nfs? ( net-fs/libnfs:= )
opengl? ( media-libs/glu )
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.0.2j:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ !libressl? ( >=dev-libs/openssl-1.0.2j:0= )
+ libressl? ( dev-libs/libressl:0= )
pulseaudio? ( media-sound/pulseaudio )
samba? ( >=net-fs/samba-3.4.6[smbclient(+)] )
sftp? ( net-libs/libssh[sftp] )
@@ -225,7 +223,7 @@ src_configure() {
-DENABLE_NONFREE=$(usex nonfree)
-DENABLE_OPENGLES=$(usex gles)
-DENABLE_OPENGL=$(usex opengl)
- -DENABLE_OPENSSL=$(usex ssl)
+ -DENABLE_OPENSSL=ON
-DENABLE_OPTICAL=$(usex dvd)
-DENABLE_PLIST=$(usex airplay)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)