summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-08-18 19:10:40 +1000
committerMichał Górny <mgorny@gentoo.org>2020-09-01 12:29:21 +0200
commit93ad57d3ae43b9bc6a222326eb03a59f848c5a0c (patch)
tree11e35710ba95cddd7312ca55f9491bb286639d88
parentmedia-libs/partio: Add python 3.7 and 3.8 support (diff)
downloadgentoo-93ad57d3ae43b9bc6a222326eb03a59f848c5a0c.tar.gz
gentoo-93ad57d3ae43b9bc6a222326eb03a59f848c5a0c.tar.bz2
gentoo-93ad57d3ae43b9bc6a222326eb03a59f848c5a0c.zip
media-libs/partio: Version bump to 1.10.1
This bumps partio to 1.10.1, and contains support for python 3.7 and 3.8 Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Closes: https://bugs.gentoo.org/696600 Closes: https://bugs.gentoo.org/737398 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--media-libs/partio/Manifest1
-rw-r--r--media-libs/partio/partio-1.10.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/partio/Manifest b/media-libs/partio/Manifest
index 6ed91b8ecc2a..331a9dcc23ae 100644
--- a/media-libs/partio/Manifest
+++ b/media-libs/partio/Manifest
@@ -1,2 +1,3 @@
DIST partio-1.1.0_p20170829.tar.gz 275959 BLAKE2B 441c2d0ab9dd91fa52a826d49f7448dc4d5d0a8d6b72bdb58793dd3c97d86739b25e582bdff41160599489a2835ad8e68676012cb70ef8edff062df3205ab209 SHA512 daedb23ae2b89d3f2ef36ef13afc624a663b3fab91c22f9a454439ff3bc194b78a87e37c9133f6948567ab3b183eff960bb51951b0427cff8c1c29099b6578d6
+DIST partio-1.10.1.tar.gz 333129 BLAKE2B 82d1dd36e9854e221af036d386ecdc558ac032ad7cd720403787ddc83ac236f05fd86e8c07ade07ca93b06a12ac2b834c96a6d43265e396934e44a815df003d3 SHA512 7d3c6449ebd1e8b8a29298a3119acfd1036970b287e9cd5f288a63c7e2b3bf451e9e1ba8fc72f203e225eb2b062d59cd7373817ccc6467de67427d02c0b12477
DIST partio-1.5.4.tar.gz 291617 BLAKE2B 638fae984d392e1e6c95862ad9a8dd8b8a0d80b2c83dfd03e887af36e420d15fd67f0b2c71e5e8c335668b512660bf14f03a1329ac0d7a48431674a51043585d SHA512 967da5b648b19c45bd0c3c8ff56f891e2d54a07b2cd113f18d5d0b646cbfabd968e31ee48c0e167bf9a911d8d5af42d5291b355da305a2b9134fa78fc23e5636
diff --git a/media-libs/partio/partio-1.10.1.ebuild b/media-libs/partio/partio-1.10.1.ebuild
new file mode 100644
index 000000000000..011f45bc931b
--- /dev/null
+++ b/media-libs/partio/partio-1.10.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+inherit cmake python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wdas/partio.git"
+else
+ SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Library for particle IO and manipulation"
+HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ dev-lang/swig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ sys-libs/zlib
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package doc Doxygen)
+ )
+ cmake_src_configure
+}