summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-01 08:08:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-01 08:36:40 +0200
commit93ce898f931e081f1588f0406d90b5b0189cf3c0 (patch)
tree4c5a97733c497b3fa9cc623ad66640cc53f70c48
parentdev-python/toposort: 1.7 version bump (diff)
downloadgentoo-93ce898f931e081f1588f0406d90b5b0189cf3c0.tar.gz
gentoo-93ce898f931e081f1588f0406d90b5b0189cf3c0.tar.bz2
gentoo-93ce898f931e081f1588f0406d90b5b0189cf3c0.zip
dev-python/nltk: Bump to 3.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nltk/Manifest1
-rw-r--r--dev-python/nltk/nltk-3.6.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/nltk/Manifest b/dev-python/nltk/Manifest
index 413360346483..f141c1cf54d8 100644
--- a/dev-python/nltk/Manifest
+++ b/dev-python/nltk/Manifest
@@ -1,2 +1,3 @@
DIST nltk-3.6.2.tar.gz 2819833 BLAKE2B 9796822c35c524432e9790d0890b4388fbaa85b659e5415037422a22e8edbaf20775196b4416f441d62592b387066de9f7741b988c0d463349fc5c906bfd75b2 SHA512 3fd2cba52377613f35f6574f859482de987f969cfc8d4243a859be365ab1bd8300f9013dcedc6caeff7aa7fc035b331a47b557027209ca9a85b0cc7fbde44d6d
DIST nltk-3.6.3.tar.gz 2824924 BLAKE2B fcab6647f43f4bf139857e9f4202aee688f564851976ed6a183e47361451fae771318346724e41f198b82cebdd5a47f151aaf932099143ef6faa2a77430fbfb4 SHA512 fe7244967df018670501304d1a8aa50a0f4d42bb0c73cc5e202eeab6a0f5da1eaed9b961f6026e3b8ae4b0393d788bcb58b263ba22a3ce6f5644022736035f98
+DIST nltk-3.6.4.tar.gz 2828051 BLAKE2B f757c9c6d0b5ab6105e90e1a46fc6671d5f661f9b1b58026ccb43c00ff4969a98cbc2005670e0a81218ef4d18e45c37bb380c53be4ca60984344b11a0c8dbc54 SHA512 ba9acaa596c7f9246cd2f8da37b58146021dc2c246306fab68a37ef833a5a346b1aa7033d43b9e72b52aeda1cf8e303c7c690d1ca439f6f58dc673aa63a37298
diff --git a/dev-python/nltk/nltk-3.6.4.ebuild b/dev-python/nltk/nltk-3.6.4.ebuild
new file mode 100644
index 000000000000..11dd1a3283d2
--- /dev/null
+++ b/dev-python/nltk/nltk-3.6.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+HOMEPAGE="https://www.nltk.org/ https://github.com/nltk/nltk/"
+SRC_URI="https://github.com/nltk/nltk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="tk"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ >=dev-python/nltk-data-20200312-r1
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twython[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )"
+PDEPEND="dev-python/nltk-data"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # requires unpackaged pycrfsuite
+ sed -i -e '/>>>/s@$@ # doctest: +SKIP@' nltk/tag/crf.py || die
+ # replace fetching from network with duplicate file URL
+ sed -e 's@https://raw.githubusercontent.com/nltk/nltk/develop/nltk/test/toy.cfg@nltk:grammars/sample_grammars/toy.cfg@' \
+ -i nltk/test/data.doctest || die
+ # requires X and hangs in Xvfb
+ sed -e 's:test_plot:_&:' \
+ -i nltk/test/unit/test_cfd_mutation.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ cd nltk/test || die
+ distutils-r1_src_test
+}