summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-07-13 13:25:00 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-07-13 13:29:14 -0400
commit951bbd7e60ff137134aec0026703b5ecf87c56f4 (patch)
tree4cdb4b0d730327f4db115f7fb8474b4a859bd9e4
parentnet-analyzer/ffp: add libressl support (diff)
downloadgentoo-951bbd7e60ff137134aec0026703b5ecf87c56f4.tar.gz
gentoo-951bbd7e60ff137134aec0026703b5ecf87c56f4.tar.bz2
gentoo-951bbd7e60ff137134aec0026703b5ecf87c56f4.zip
net-analyzer/flow-tools: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--net-analyzer/flow-tools/flow-tools-0.68.5.1-r4.ebuild72
-rw-r--r--net-analyzer/flow-tools/flow-tools-0.68.5.1-r5.ebuild72
-rw-r--r--net-analyzer/flow-tools/flow-tools-0.68.5.1-r6.ebuild13
3 files changed, 8 insertions, 149 deletions
diff --git a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r4.ebuild b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r4.ebuild
deleted file mode 100644
index ea94ae586de1..000000000000
--- a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils user
-
-DESCRIPTION="library and programs to collect, send, process, and generate reports from NetFlow data"
-HOMEPAGE="https://code.google.com/p/flow-tools/"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug mysql postgres ssl static-libs"
-
-RDEPEND="sys-apps/tcp-wrappers
- sys-libs/zlib
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- ssl? ( dev-libs/openssl )"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison"
-
-DOCS=( ChangeLog README SECURITY TODO )
-
-pkg_setup() {
- enewgroup flows
- enewuser flows -1 -1 /var/lib/flows flows
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-run.patch
- epatch "${FILESDIR}"/${P}-syslog.patch
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(usex mysql --with-mysql '') \
- $(usex postgres --with-postgresql=yes --with-postgresql=no) \
- $(usex ssl --with-openssl '') \
- --sysconfdir=/etc/flow-tools
-}
-
-src_install() {
- default
-
- prune_libtool_files
-
- exeinto /var/lib/flows/bin
- doexe "${FILESDIR}"/linkme
-
- keepdir /var/lib/flows/ft
-
- newinitd "${FILESDIR}/flowcapture.initd" flowcapture
- newconfd "${FILESDIR}/flowcapture.confd" flowcapture
-
- fowners flows:flows /var/lib/flows
- fowners flows:flows /var/lib/flows/bin
- fowners flows:flows /var/lib/flows/ft
-
- fperms 0755 /var/lib/flows
- fperms 0755 /var/lib/flows/bin
-}
-
-pkg_preinst() {
- enewgroup flows
- enewuser flows -1 -1 /var/lib/flows flows
-}
diff --git a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r5.ebuild b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r5.ebuild
deleted file mode 100644
index ea94ae586de1..000000000000
--- a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r5.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils user
-
-DESCRIPTION="library and programs to collect, send, process, and generate reports from NetFlow data"
-HOMEPAGE="https://code.google.com/p/flow-tools/"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug mysql postgres ssl static-libs"
-
-RDEPEND="sys-apps/tcp-wrappers
- sys-libs/zlib
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- ssl? ( dev-libs/openssl )"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison"
-
-DOCS=( ChangeLog README SECURITY TODO )
-
-pkg_setup() {
- enewgroup flows
- enewuser flows -1 -1 /var/lib/flows flows
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-run.patch
- epatch "${FILESDIR}"/${P}-syslog.patch
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(usex mysql --with-mysql '') \
- $(usex postgres --with-postgresql=yes --with-postgresql=no) \
- $(usex ssl --with-openssl '') \
- --sysconfdir=/etc/flow-tools
-}
-
-src_install() {
- default
-
- prune_libtool_files
-
- exeinto /var/lib/flows/bin
- doexe "${FILESDIR}"/linkme
-
- keepdir /var/lib/flows/ft
-
- newinitd "${FILESDIR}/flowcapture.initd" flowcapture
- newconfd "${FILESDIR}/flowcapture.confd" flowcapture
-
- fowners flows:flows /var/lib/flows
- fowners flows:flows /var/lib/flows/bin
- fowners flows:flows /var/lib/flows/ft
-
- fperms 0755 /var/lib/flows
- fperms 0755 /var/lib/flows/bin
-}
-
-pkg_preinst() {
- enewgroup flows
- enewuser flows -1 -1 /var/lib/flows flows
-}
diff --git a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r6.ebuild b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r6.ebuild
index 501d9f919334..087e3c9d9048 100644
--- a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r6.ebuild
+++ b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r6.ebuild
@@ -1,24 +1,27 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils user
-DESCRIPTION="library and programs to collect, send, process, and generate reports from NetFlow data"
+DESCRIPTION="library and programs to process reports from NetFlow data"
HOMEPAGE="https://code.google.com/p/flow-tools/"
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug mysql postgres ssl static-libs"
+IUSE="debug libressl mysql postgres ssl static-libs"
RDEPEND="sys-apps/tcp-wrappers
sys-libs/zlib
mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql )
- ssl? ( dev-libs/openssl )"
+ postgres? ( dev-db/postgresql:* )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
DEPEND="${RDEPEND}
sys-devel/flex