summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-12 10:05:00 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-12 10:06:33 +0200
commit95f69d625aa06e2e47289e0044eca43b6c85a3c9 (patch)
tree13296d0afcf7cfdf9de8d9ec6a111924af819cf0
parentsys-fs/aufs3: Bump to latest aufs release (diff)
downloadgentoo-95f69d625aa06e2e47289e0044eca43b6c85a3c9.tar.gz
gentoo-95f69d625aa06e2e47289e0044eca43b6c85a3c9.tar.bz2
gentoo-95f69d625aa06e2e47289e0044eca43b6c85a3c9.zip
sci-chemistry/pymol-plugins-dynamics: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/Manifest1
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-dynamics/Manifest b/sci-chemistry/pymol-plugins-dynamics/Manifest
index a607e37c50b4..258493d5b263 100644
--- a/sci-chemistry/pymol-plugins-dynamics/Manifest
+++ b/sci-chemistry/pymol-plugins-dynamics/Manifest
@@ -1 +1,2 @@
DIST pymol-plugins-dynamics-1.2.0.tar.gz 725163 SHA256 edf9bddbbce41ee5319bfd0b28d6e0b0eba56e8b2d8a300d510be8ff5894704f SHA512 7e8d62ea58cb88348136fccd132d9a1faaa3474c0a0f821e729ced777620e2083b1b0606d79fc75802755c96c5eb0b90e08b00e5c865ecbaaee2b837f56987de WHIRLPOOL 07061d3b0840fef0025be55b90fca013afc1ea58308d6ee11a8b74321de4f1c24760b1cf141b0a86678c5cf652c8890cdf2c4e0da60403c8454e04b003e20aaa
+DIST pymol-plugins-dynamics-2.0.4.tar.gz 821563 SHA256 358452e0d8589ffae28fe486eeca0be353f17f1fdde9f05f548025b241afabe5 SHA512 befad8b5c09ddba89b9e00bd712a2af7202e312b2ebee7722cbeec5698125dd7614463465d79c17c805714ba23ca1188c64610789e90c93bb0ad7572841ebf25 WHIRLPOOL 039e40c7c57a242476e72a351ecc099201021f479762c2eb29bdad25b72c11c33295e8f9707ece486235efb1b205524e479cd4ae57639d1410515a75d2221989
diff --git a/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild
new file mode 100644
index 000000000000..1111c6110436
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+MY_PN="Dynamics"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular dynamics in Pymol"
+HOMEPAGE="https://github.com/tomaszmakarewicz/Dynamics"
+SRC_URI="https://github.com/tomaszmakarewicz/Dynamics/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sci-chemistry/prody[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( manual.odt )
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_parallel_foreach_impl python_domodule pymol_plugin_dynamics.py
+}