summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-04-25 09:03:27 +0900
committerJoonas Niilola <juippis@gentoo.org>2021-05-05 09:30:35 +0300
commit9678a5d0ae40d282a8c3bd219a2d3193e413a621 (patch)
tree75690c7864de7016f052371ca4526e53cd8cca28
parentsci-mathematics/cgal: version bump to 5.2.1 (diff)
downloadgentoo-9678a5d0ae40d282a8c3bd219a2d3193e413a621.tar.gz
gentoo-9678a5d0ae40d282a8c3bd219a2d3193e413a621.tar.bz2
gentoo-9678a5d0ae40d282a8c3bd219a2d3193e413a621.zip
dev-cpp/benchmark: Version bump to 1.5.3
Closes: https://bugs.gentoo.org/785466 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20531 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-cpp/benchmark/Manifest1
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/Manifest b/dev-cpp/benchmark/Manifest
index 654804a904fe..483606d8a3c3 100644
--- a/dev-cpp/benchmark/Manifest
+++ b/dev-cpp/benchmark/Manifest
@@ -1,2 +1,3 @@
DIST benchmark-1.5.1.tar.gz 154896 BLAKE2B cb8d74b3e6662e35ea12809d8b62d1e3a6849668840c84697e7f4b2d29eaf68688bb1cda6f43c170e70366de88a93af79bb709d55dfc8d79140c11a31855a46b SHA512 1e8782ab6846b8b29c5eea41ed1ba19dd92a46a135cf74acdc588e2cd5ef05581c644d20fc0d6403456d65417538e1db80109ae87989601298b2fc56ae3c3161
DIST benchmark-1.5.2.tar.gz 160235 BLAKE2B af14235d174e39b8bbb0a44960834b7d13b1aed6cd4494efa9eb58d32c051efdf244258a33b83b82ad82aa69917356c35ccb470caea838cb6fd7eda37f0f80f6 SHA512 a071613f3af669296aa613e0e64726bdcf27cc3db331d8003f49164581cd6935a86641ec435118ea590a9d722a926d3fef740e938e1a5f6eba8e2a5a615da1b0
+DIST benchmark-1.5.3.tar.gz 163465 BLAKE2B cea8929c5595be55e74e6232eb147a00c656cc5afe6f5b9d3d788de002c51c40c46012461a7c6840aff9e590ed4304f24a31249402bbbeae28ec443a433a2e53 SHA512 11f726686ad8b36870fc2a3542fad4c52a58df2eb580564dcfdfb154fe6ac00dbbf69c514395148d7ab11a45e40e869549cf971462c384f59cbae5fa60160e3b
diff --git a/dev-cpp/benchmark/benchmark-1.5.3.ebuild b/dev-cpp/benchmark/benchmark-1.5.3.ebuild
new file mode 100644
index 000000000000..31ebd325a360
--- /dev/null
+++ b/dev-cpp/benchmark/benchmark-1.5.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 -hppa ~ppc64 ~x86"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBENCHMARK_ENABLE_TESTING=$(usex test)
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
+ -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
+ )
+
+ use debug || append-cppflags -DNDEBUG
+
+ cmake_src_configure
+}