summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-20 09:02:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-20 10:32:51 +0200
commit968c15f6bc8af72efb71076b8186d4c6d8e0b5ab (patch)
treee3ffed7d49e39fefc419ff4ec14272f697e45d79
parentsys-auth/polkit-qt: 0.114.0 version bump (diff)
downloadgentoo-968c15f6bc8af72efb71076b8186d4c6d8e0b5ab.tar.gz
gentoo-968c15f6bc8af72efb71076b8186d4c6d8e0b5ab.tar.bz2
gentoo-968c15f6bc8af72efb71076b8186d4c6d8e0b5ab.zip
dev-libs/libical: Add missing dev-util/gtk-doc BDEPEND w/ doc && glib
Closes: https://bugs.gentoo.org/791739 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libical/libical-3.0.10.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/dev-libs/libical/libical-3.0.10.ebuild b/dev-libs/libical/libical-3.0.10.ebuild
index 5ce88999e056..bfe509899c72 100644
--- a/dev-libs/libical/libical-3.0.10.ebuild
+++ b/dev-libs/libical/libical-3.0.10.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{7,8,9} )
VALA_USE_DEPEND="vapigen"
inherit cmake python-any-r1 vala
-DESCRIPTION="An implementation of basic iCAL protocols"
+DESCRIPTION="Implementation of basic iCAL protocols"
HOMEPAGE="https://github.com/libical/libical"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
@@ -20,17 +20,6 @@ REQUIRED_USE="introspection? ( glib ) vala? ( introspection )"
RESTRICT="!test? ( test )"
-BDEPEND="
- dev-lang/perl
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- introspection? ( dev-libs/gobject-introspection )
- test? (
- ${PYTHON_DEPS}
- glib? ( $(python_gen_any_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]') )
- )
- vala? ( $(vala_depend) )
-"
COMMON_DEPEND="
dev-libs/icu:=
berkdb? ( sys-libs/db:= )
@@ -42,6 +31,20 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
sys-libs/timezone-data
"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ glib? ( dev-util/gtk-doc )
+ )
+ introspection? ( dev-libs/gobject-introspection )
+ test? (
+ ${PYTHON_DEPS}
+ glib? ( $(python_gen_any_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]') )
+ )
+ vala? ( $(vala_depend) )
+"
DOCS=(
AUTHORS ReadMe.txt ReleaseNotes.txt TEST THANKS TODO
@@ -100,7 +103,7 @@ src_test() {
}
src_install() {
- use doc && HTML_DOCS=( "${BUILD_DIR}"/apidocs/html/. )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/apidocs/html/. )
cmake_src_install