summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-15 20:47:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-15 20:48:02 -0500
commit97177c0d81beb72ec5129ebca61cebea88f16870 (patch)
treea9d2f14476d580e8ab869c59f0999de64961443e
parentdev-python/boto3: remove version 1.3.0 (diff)
downloadgentoo-97177c0d81beb72ec5129ebca61cebea88f16870.tar.gz
gentoo-97177c0d81beb72ec5129ebca61cebea88f16870.tar.bz2
gentoo-97177c0d81beb72ec5129ebca61cebea88f16870.zip
games-rpg/sumwars: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
-rw-r--r--games-rpg/sumwars/sumwars-0.5.8-r1.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/games-rpg/sumwars/sumwars-0.5.8-r1.ebuild b/games-rpg/sumwars/sumwars-0.5.8-r1.ebuild
new file mode 100644
index 000000000000..19640e4af4e9
--- /dev/null
+++ b/games-rpg/sumwars/sumwars-0.5.8-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils eutils flag-o-matic gnome2-utils
+
+DESCRIPTION="a multi-player, 3D action role-playing game"
+HOMEPAGE="http://sumwars.org"
+SRC_URI="mirror://sourceforge/sumwars/${P//_/-}-src.tar.bz2"
+
+LICENSE="GPL-3 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools debug"
+
+LANGS="de en it pl pt ru uk"
+for L in ${LANGS} ; do
+ IUSE="${IUSE} l10n_${L}"
+done
+unset L
+
+RDEPEND="
+ >=dev-games/cegui-0.8[ogre]
+ >=dev-games/ogre-1.7.4-r1[freeimage,opengl]
+ dev-games/ois
+ dev-games/physfs
+ >=dev-lang/lua-5.1:0
+ >=dev-libs/tinyxml-2.6.2-r2
+ media-libs/freealut
+ media-libs/openal
+ media-libs/libogg
+ media-libs/libvorbis
+ >=net-libs/enet-1.3.0
+ x11-libs/libX11
+ x11-libs/libXrandr
+ tools? ( dev-libs/boost )"
+DEPEND=${RDEPEND}
+
+S=${WORKDIR}/${PN}-${PV%_*}
+
+src_configure() {
+ # QA
+ append-flags -fno-strict-aliasing
+
+ use debug && CMAKE_BUILD_TYPE=Debug
+
+ local l langs
+ for l in ${LANGS}; do
+ if use l10n_${l}; then
+ langs="${langs} ${l}"
+ fi
+ done
+
+ [[ -z "${langs}" ]] && langs="en"
+
+ # configure sumwars with cmake
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=""
+ -DSUMWARS_BUILD_TOOLS="$(usex tools)"
+ -DSUMWARS_DOC_DIR="/usr/share/doc/${PF}"
+ -DSUMWARS_EXECUTABLE_DIR="/usr/bin"
+ -DSUMWARS_LANGUAGES="${langs}"
+ -DSUMWARS_NO_ENET=ON
+ -DSUMWARS_NO_TINYXML=ON
+ -DSUMWARS_PORTABLE_MODE=OFF
+ -DSUMWARS_POST_BUILD_COPY=OFF
+ -DSUMWARS_RANDOM_REGIONS=ON
+ -DSUMWARS_SHARE_DIR="/usr/share/${PN}"
+ -DSUMWARS_STANDALONE_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon -s 128 share/icon/SumWarsIcon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Summoning Wars"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}