summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-04-01 21:36:57 +0100
committerJustin Lecher <jlec@gentoo.org>2018-04-01 21:51:33 +0100
commit978c8e081d9b625ce7414fa19839afe80cac52f1 (patch)
tree465a1600235abcd994e22e8646e8bc1bdacc2b70
parentsys-kernel/aufs-sources: Bump to latest aufs, genpatches and linux release (diff)
downloadgentoo-978c8e081d9b625ce7414fa19839afe80cac52f1.tar.gz
gentoo-978c8e081d9b625ce7414fa19839afe80cac52f1.tar.bz2
gentoo-978c8e081d9b625ce7414fa19839afe80cac52f1.zip
sys-cluster/ucx: New package
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/metadata.xml12
-rw-r--r--sys-cluster/ucx/ucx-1.2.2.ebuild29
3 files changed, 42 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
new file mode 100644
index 000000000000..e0076771f8a2
--- /dev/null
+++ b/sys-cluster/ucx/Manifest
@@ -0,0 +1 @@
+DIST ucx-1.2.2.tar.gz 1513611 BLAKE2B 488b9b3cecc2c617b1209036e1342e4378459db6a5e93eab1d88dfe80cb0d9c8013c767413206f0fbd0105557ed89994ab510421068d709101336a7b3d2eac5e SHA512 515c382826310b9aa7179ab19ceb76a881a41e6786514219b7f703c6144fa57ca141bceb3b80523ae1b4e2a4b13e9abcb9df063612b376d894c5cd81cdc00571
diff --git a/sys-cluster/ucx/metadata.xml b/sys-cluster/ucx/metadata.xml
new file mode 100644
index 000000000000..d11a30befa7f
--- /dev/null
+++ b/sys-cluster/ucx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/ucx/ucx-1.2.2.ebuild b/sys-cluster/ucx/ucx-1.2.2.ebuild
new file mode 100644
index 000000000000..0b581f7bf566
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="http://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ default
+ sed \
+ -e '/^BASE_CFLAGS/s:=.*:=:g' \
+ -i config/m4/compiler.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" \
+ econf \
+ --disable-compiler-opt
+}