summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-11 21:01:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-11 21:01:49 +0200
commit97afdf6db50c7466858dc4f80581fd38bcd46df8 (patch)
treec0db8d2c779da6eac3982d039285db0931b886dd
parentdev-python/cython: arm stable, bug #615344 (diff)
downloadgentoo-97afdf6db50c7466858dc4f80581fd38bcd46df8.tar.gz
gentoo-97afdf6db50c7466858dc4f80581fd38bcd46df8.tar.bz2
gentoo-97afdf6db50c7466858dc4f80581fd38bcd46df8.zip
net-analyzer/ifstatus: No gcc6 patch in stable ebuild (bug #618234).
Added unstable -r2 ebuild instead. Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild1
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild44
2 files changed, 44 insertions, 1 deletions
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
index 10f512067d0b..219bdaa49c5d 100644
--- a/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
@@ -23,7 +23,6 @@ S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}/${P}-gcc43.patch"
"${FILESDIR}/${P}-tinfo.patch"
- "${FILESDIR}/${P}-gcc6.patch"
)
src_prepare() {
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..cc2baff02f50
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time"
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-4.2:0="
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}/${P}-gcc6.patch"
+)
+
+src_prepare() {
+ default
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}