summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-08-19 12:07:34 +0200
committerUltrabug <ultrabug@gentoo.org>2016-08-19 12:07:50 +0200
commit980866f56fa904ee285979b42817bff9c09c316b (patch)
tree31a76495fb61ae3d4db7d8bba669f44aa11476a9
parentsys-kernel/linux-firmware: Cleanup due to bug #42273 (diff)
downloadgentoo-980866f56fa904ee285979b42817bff9c09c316b.tar.gz
gentoo-980866f56fa904ee285979b42817bff9c09c316b.tar.bz2
gentoo-980866f56fa904ee285979b42817bff9c09c316b.zip
dev-libs/mongo-cxx-driver: version bump, work on #570770
Package-Manager: portage-2.2.27
-rw-r--r--dev-libs/mongo-cxx-driver/Manifest1
-rw-r--r--dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.0-fix-scons.patch54
-rw-r--r--dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2.ebuild70
3 files changed, 125 insertions, 0 deletions
diff --git a/dev-libs/mongo-cxx-driver/Manifest b/dev-libs/mongo-cxx-driver/Manifest
index c54ddab1de9e..7143cdb887e6 100644
--- a/dev-libs/mongo-cxx-driver/Manifest
+++ b/dev-libs/mongo-cxx-driver/Manifest
@@ -1,3 +1,4 @@
DIST legacy-0.0-26compat-2.6.7.tar.gz 1512331 SHA256 a77165e7ad0c1ff8e246adc5e60b9ebb18eec7f0cc18682a33498c12d7cab0ba SHA512 edf13d5b7802c3b2e9772f08949fd0c412f2cd25ec6d05ff4e8c1f25c3e3506da6ebbd7b017ceec5478585c84e9fa44c66a5094ad3e7a7373187d3fb3c1c1222 WHIRLPOOL f64cfded6a02e241b4b59b3394bcec1cf7df4bc175aba261893d8b24106760eb3899b85b520c5f9af9d929d93ad29ed6d2ef1e11d662b7a331f143f2b88d637c
DIST legacy-1.0.0.tar.gz 1569156 SHA256 1350dfdcdb3969e472bf83eec08378f771196c47e70b474e7349c816acb0cca4 SHA512 e161972715fe45b777ee3d9c7e788ee3a808af789e2c1248af1dde3d3f3936e29f619e039f53210cdd3fc6a6bd8a02c101facf49c61759c6f108d25c5c03b59b WHIRLPOOL 7d5c8fc6d011f219652bc6cc5a8dd59fac899a95ca3bde22fc76a2505cb7393a1762681f77cfc9295028a427e875c0155ee7046fa9d1c2e4e52d340a19e2c925
DIST legacy-1.0.5.tar.gz 1573929 SHA256 7e83927285f294ef5b98c4bad022c3dc8e0af5628595abfb676f3d027a8bbebe SHA512 e904d73f78ffbc1ce18ffa11dd7e3dddd67c730b6e79bace0e48c0be4e8ffd7b5fe12e1373e42ad941d8fc239ef031a47d39ff04aaf3f0a5ecf88115c816bc70 WHIRLPOOL 8512c9a694288d71d0ad3383457a021a905d384c29c1cdbe426adf3aee9d59406518657d263f9b7d6dcb943ad1268dfd1ac007318139ac409254039a29d62c7c
+DIST legacy-1.1.2.tar.gz 1577527 SHA256 8c52cae798086c3e9d0e6fe488c3378601db858cc71944b6b83440d8b00298f4 SHA512 a0b21719db8205a16c574ce21565577787ea00cf2492353bcd4dd79a7ef3b7d685287be47e6eee59fad46c6fa2ac3c6a0e00c26ef88be8b17e9d93fbc763cb10 WHIRLPOOL 84563ee7eedcd89a08515e8a2284edd7822042f3dcaf24adab905533bfa65c367f071eaa5869a5308f6a1689f30aeed37796a35bf977277b247b295ebeefde8b
diff --git a/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.0-fix-scons.patch b/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.0-fix-scons.patch
new file mode 100644
index 000000000000..89ec03b11f30
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.1.0-fix-scons.patch
@@ -0,0 +1,54 @@
+--- /tmp/a/SConstruct 2016-06-21 21:15:24.000000000 +0200
++++ /tmp/b/SConstruct 2016-08-19 11:40:45.916695952 +0200
+@@ -865,7 +865,6 @@
+
+ # -Winvalid-pch Warn if a precompiled header (see Precompiled Headers) is found in the search path but can't be used.
+ env.Append( CCFLAGS=["-fPIC",
+- "-ggdb",
+ "-pthread",
+ "-Wall",
+ "-Wsign-compare",
+@@ -873,13 +872,13 @@
+ "-Winvalid-pch"] )
+ # env.Append( " -Wconversion" ) TODO: this doesn't really work yet
+ if linux or darwin:
+- env.Append( CCFLAGS=["-pipe"] )
+ if not has_option("disable-warnings-as-errors"):
+ env.Append( CCFLAGS=["-Werror"] )
+
+ env.Append( CPPDEFINES=["_FILE_OFFSET_BITS=64"] )
+- env.Append( CXXFLAGS=["-Wnon-virtual-dtor", "-Woverloaded-virtual"] )
+ env.Append( LINKFLAGS=["-fPIC"] )
++ env.Append( CXXFLAGS=os.environ['CXXFLAGS'] )
++ env.Append( LINKFLAGS=os.environ['LDFLAGS'] )
+
+ # SERVER-9761: Ensure early detection of missing symbols in dependent libraries at program
+ # startup.
+@@ -905,11 +904,6 @@
+ env.Append( CXXFLAGS=" -fprofile-arcs -ftest-coverage " )
+ env.Append( LINKFLAGS=" -fprofile-arcs -ftest-coverage " )
+
+- if optBuild:
+- env.Append( CCFLAGS=["-O3"] )
+- else:
+- env.Append( CCFLAGS=["-O0"] )
+-
+ if debugBuild:
+ if not optBuild:
+ env.Append( CCFLAGS=["-fstack-protector"] )
+@@ -932,7 +926,6 @@
+ except OSError:
+ pass
+
+-env.Prepend(CPPPATH=['$VARIANT_DIR/third_party/gtest-1.7.0/include'])
+
+ boostSuffixList = ["-mt", ""]
+ if get_option("boost-lib-search-suffixes") is not None:
+@@ -1143,6 +1136,7 @@
+ # Clang likes to warn about unused functions, which seems a tad aggressive and breaks
+ # -Werror, which we want to be able to use.
+ AddToCCFLAGSIfSupported(myenv, '-Wno-unused-function')
++ AddToCCFLAGSIfSupported(myenv, '-Wno-unused-variable')
+
+ # TODO: Note that the following two flags are added to CCFLAGS even though they are
+ # really C++ specific. We need to do this because SCons passes CXXFLAGS *before*
diff --git a/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2.ebuild b/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2.ebuild
new file mode 100644
index 000000000000..724fdce18ff3
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.1.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+SCONS_MIN_VERSION="2.3.0"
+
+inherit eutils multilib scons-utils
+
+DESCRIPTION="C++ Driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-cxx-driver"
+SRC_URI="https://github.com/mongodb/${PN}/archive/legacy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl sasl ssl static-libs"
+
+RDEPEND="!dev-db/tokumx
+ >=dev-libs/boost-1.50[threads(+)]
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+
+# Maintainer notes
+# TODO: enable test in IUSE with
+# test? ( >=dev-cpp/gtest-1.7.0 dev-db/mongodb )
+
+DOCS=( README.md )
+
+S="${WORKDIR}/${PN}-legacy-${PV}"
+
+pkg_setup() {
+ scons_opts="--variant-dir=build --cc=$(tc-getCC) --cxx=$(tc-getCXX)"
+ scons_opts+=" --disable-warnings-as-errors --sharedclient"
+
+ if use debug; then
+ scons_opts+=" --dbg=on"
+ fi
+
+ if use prefix; then
+ scons_opts+=" --cpppath=${EPREFIX}/usr/include"
+ scons_opts+=" --libpath=${EPREFIX}/usr/$(get_libdir)"
+ fi
+
+ if use sasl; then
+ scons_opts+=" --use-sasl-client"
+ fi
+
+ if use ssl; then
+ scons_opts+=" --ssl"
+ fi
+}
+
+src_prepare() {
+ eapply_user
+ epatch "${FILESDIR}/${PN}-1.1.0-fix-scons.patch"
+}
+
+src_compile() {
+ escons "${scons_opts}" all
+}
+
+src_install() {
+ escons ${scons_opts} install --prefix="${ED}"/usr
+ use static-libs || find "${D}" -name '*.a' -delete
+}