summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2018-06-03 12:05:44 -0700
committerZac Medico <zmedico@gentoo.org>2018-06-03 13:45:49 -0700
commit989b0455c7dc09eebdd4e139be83a97881876e65 (patch)
tree1954b9a6959159147d2b9122df9cb71db35c7d17
parentsys-apps/portage: stable 2.3.40 for hppa (diff)
downloadgentoo-989b0455c7dc09eebdd4e139be83a97881876e65.tar.gz
gentoo-989b0455c7dc09eebdd4e139be83a97881876e65.tar.bz2
gentoo-989b0455c7dc09eebdd4e139be83a97881876e65.zip
dev-util/ostree: new package (from defiance-overlay)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/metadata.xml39
-rw-r--r--dev-util/ostree/ostree-2018.5.ebuild51
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
new file mode 100644
index 000000000000..efb030b2fe29
--- /dev/null
+++ b/dev-util/ostree/Manifest
@@ -0,0 +1 @@
+DIST ostree-2018.5.tar.xz 1937184 BLAKE2B ff126d2963296eb9ac270816efed7d2fbfdbcc7b0dba69007ae83e4499a46ef21a5b4e5d387de9bd387af0fe8d4086427d1aa9043c246a49676d116e919a93e6 SHA512 03854c662cddc1e0c7150bb62bbdd2990cf091ef126ddc5bb94494fee2ffb0383afb067b89d63c3e4f39849e2c8b7cabfd887d0d6fc1e7a43fda4fe7da1dc2e8
diff --git a/dev-util/ostree/metadata.xml b/dev-util/ostree/metadata.xml
new file mode 100644
index 000000000000..d31a82267686
--- /dev/null
+++ b/dev-util/ostree/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <longdescription lang="en">
+ This project is now known as "libostree", though it is
+ still appropriate to use the previous name: "OSTree" (or
+ "ostree"). The focus is on projects which use libostree's
+ shared library, rather than users directly invoking the command
+ line tools (except for build systems). However, in most of
+ the rest of the documentation, we will use the term "OSTree",
+ since it's slightly shorter, and changing all documentation
+ at once is impractical. We expect to transition to the new
+ name over time.
+
+ As implied above, libostree is both a shared library and suite
+ of command line tools that combines a "git-like" model for
+ committing and downloading bootable filesystem trees, along
+ with a layer for deploying them and managing the bootloader
+ configuration.
+
+ The core OSTree model is like git in that it checksums
+ individual files and has a content-addressed-object
+ store. It's unlike git in that it "checks out" the files
+ via hardlinks, and they thus need to be immutable to prevent
+ corruption. Therefore, another way to think of OSTree is that
+ it's just a more polished version of Linux VServer hardlinks.
+ </longdescription>
+ <use>
+ <flag name="grub">Enable grub configuration generator</flag>
+ <flag name="soup">Use libsoup for networking</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ostreedev/ostree</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/ostree/ostree-2018.5.ebuild b/dev-util/ostree/ostree-2018.5.ebuild
new file mode 100644
index 000000000000..40ad547229e2
--- /dev/null
+++ b/dev-util/ostree/ostree-2018.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostree.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/ostreedev/${PN}/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="grub selinux soup systemd zeroconf"
+RESTRICT="test"
+
+S="${WORKDIR}/lib${P}"
+COMMON_DEPEND="
+ app-arch/libarchive:=
+ app-arch/xz-utils:=
+ app-crypt/gpgme:=
+ dev-libs/glib:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ dev-libs/openssl:=
+ net-misc/curl:=
+ sys-apps/util-linux:=
+ sys-fs/fuse:=
+ sys-libs/zlib:=
+
+ grub? ( sys-boot/grub:* )
+ selinux? ( sys-libs/libselinux:= )
+ soup? ( net-libs/libsoup:= )
+ systemd? ( sys-apps/systemd:= )
+ zeroconf? ( net-dns/avahi:* )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ econf \
+ --with-crypto=openssl \
+ --with-curl \
+ --with-openssl \
+ $(use_with soup) \
+ $(use_with selinux ) \
+ $(use_with zeroconf avahi)
+}