summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:59:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:59:48 +0200
commit99c9d92b69ec81c6de4f698bce511e0b4a609122 (patch)
treece76a70deec5b92b98e19cd0aee4e39a7e3d6f46
parentdev-ros/depth_image_proc: Initial import. Ebuild by me. (diff)
downloadgentoo-99c9d92b69ec81c6de4f698bce511e0b4a609122.tar.gz
gentoo-99c9d92b69ec81c6de4f698bce511e0b4a609122.tar.bz2
gentoo-99c9d92b69ec81c6de4f698bce511e0b4a609122.zip
dev-ros/image_proc: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/image_proc/Manifest1
-rw-r--r--dev-ros/image_proc/image_proc-1.12.14.ebuild29
-rw-r--r--dev-ros/image_proc/image_proc-9999.ebuild29
-rw-r--r--dev-ros/image_proc/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/image_proc/Manifest b/dev-ros/image_proc/Manifest
new file mode 100644
index 000000000000..0cc1356d6b68
--- /dev/null
+++ b/dev-ros/image_proc/Manifest
@@ -0,0 +1 @@
+DIST image_pipeline-1.12.14.tar.gz 118296 SHA256 8e3b756932a821b4387b7f86ca9fc5233ebb2a13541b220b866e42ea6f92b17f SHA512 724b6d20edab1436c51a05f4399b852cabab74c5e04dea97f53a256fb512b4dbfc97fd6e7d74d41bfd7d92fe183aa86a993a39b8687c27dc7b7f85d1a1c81b94 WHIRLPOOL 394343ddf299f6c7e26c0a2f45e49edc2c4047a0ccd15885a998fa902bb7373fa44181f06adc222483a285f32df800e0b268485cb2fd98e54956929056868d5d
diff --git a/dev-ros/image_proc/image_proc-1.12.14.ebuild b/dev-ros/image_proc/image_proc-1.12.14.ebuild
new file mode 100644
index 000000000000..fc4695ace629
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.12.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/image_proc/image_proc-9999.ebuild b/dev-ros/image_proc/image_proc-9999.ebuild
new file mode 100644
index 000000000000..fc4695ace629
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/image_proc/metadata.xml b/dev-ros/image_proc/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/image_proc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>