summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-11 16:28:56 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-11 17:55:47 -0500
commit9bfa1265902adccac7f66d861a4edb2a91ba9f47 (patch)
tree1111610f156302e5b9367ed7839297ad1e6b1d75
parentgames-misc/gBhed: remove deprecated games eclass (diff)
downloadgentoo-9bfa1265902adccac7f66d861a4edb2a91ba9f47.tar.gz
gentoo-9bfa1265902adccac7f66d861a4edb2a91ba9f47.tar.bz2
gentoo-9bfa1265902adccac7f66d861a4edb2a91ba9f47.zip
games-misc/lucidlife: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
-rw-r--r--games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch4
-rw-r--r--games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild42
2 files changed, 44 insertions, 2 deletions
diff --git a/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch b/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch
index af74e85e8c77..77bd7092b812 100644
--- a/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch
+++ b/games-misc/lucidlife/files/lucidlife-0.9.2-underlink.patch
@@ -1,5 +1,5 @@
---- src/Makefile.am.old 2011-06-17 17:31:54.078600741 +0200
-+++ src/Makefile.am 2011-06-17 17:32:05.491299944 +0200
+--- a/src/Makefile.am 2011-06-17 17:31:54.078600741 +0200
++++ b/src/Makefile.am 2011-06-17 17:32:05.491299944 +0200
@@ -2,7 +2,7 @@
-DDATADIR=\""$(datadir)/lucidlife"\" \
-DDOCDIR=\""$(datadir)/doc/lucidlife"\"
diff --git a/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild b/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..9643c9cb131d
--- /dev/null
+++ b/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A Conway's Life simulator written in GTK+2 - fork from Gtklife"
+HOMEPAGE="http://gtk-apps.org/content/show.php/LucidLife?content=130867"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gnome-vfs.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+ intltoolize --force --copy --automake || die
+}
+
+src_install() {
+ emake install \
+ desktopdir=/usr/share/applications \
+ pixmapdir=/usr/share/pixmaps \
+ DESTDIR="${D}"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}