summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-07-25 16:43:57 -0400
committerTim Harder <radhermit@gentoo.org>2016-07-25 16:45:57 -0400
commit9d1d0ab8c38ba133d96cb849cb64a3ffe7b25752 (patch)
tree1044abb393e7c81d6061bc8647ccb2d05ccd9862
parentmedia-video/vlc: fix compiler type check (diff)
downloadgentoo-9d1d0ab8c38ba133d96cb849cb64a3ffe7b25752.tar.gz
gentoo-9d1d0ab8c38ba133d96cb849cb64a3ffe7b25752.tar.bz2
gentoo-9d1d0ab8c38ba133d96cb849cb64a3ffe7b25752.zip
app-shells/zsh: bump to EAPI 6 and skip release actions for live ebuild
-rw-r--r--app-shells/zsh/zsh-9999.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/app-shells/zsh/zsh-9999.ebuild b/app-shells/zsh/zsh-9999.ebuild
index 695369ab8bfc..e8759b00eb3f 100644
--- a/app-shells/zsh/zsh-9999.ebuild
+++ b/app-shells/zsh/zsh-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils flag-o-matic multilib prefix
@@ -47,12 +47,15 @@ if [[ ${PV} == 9999* ]] ; then
fi
src_prepare() {
- # fix zshall problem with soelim
- ln -s Doc man1
- mv Doc/zshall.1 Doc/zshall.1.soelim
- soelim Doc/zshall.1.soelim > Doc/zshall.1
-
- epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+ if [[ ${PV} != 9999* ]]; then
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ # add openrc specific options for init.d completion
+ eapply "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+ fi
cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
eprefixify "${T}"/zprofile || die
@@ -62,6 +65,8 @@ src_prepare() {
sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
fi
+ default
+
if [[ ${PV} == 9999* ]] ; then
sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
eautoreconf