summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-03-11 11:32:43 -0400
committerMatt Turner <mattst88@gentoo.org>2018-11-27 14:43:15 -0800
commit9d68e491c96541f7cbf3d5766597906561bbf512 (patch)
tree17edf40605cd82390f66f2681e974457ddc70fb3
parentdev-util/clion: remove old versions (diff)
downloadgentoo-9d68e491c96541f7cbf3d5766597906561bbf512.tar.gz
gentoo-9d68e491c96541f7cbf3d5766597906561bbf512.tar.bz2
gentoo-9d68e491c96541f7cbf3d5766597906561bbf512.zip
x11-apps/xinit: xserverrc: pass -keeptty for systemd-logind support
Closes: https://github.com/gentoo/gentoo/pull/7423 Closes: https://bugs.gentoo.org/603294 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-apps/xinit/files/xserverrc.26
-rw-r--r--x11-apps/xinit/xinit-1.4.0-r1.ebuild67
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-apps/xinit/files/xserverrc.2 b/x11-apps/xinit/files/xserverrc.2
new file mode 100644
index 000000000000..8d5b2c3f790c
--- /dev/null
+++ b/x11-apps/xinit/files/xserverrc.2
@@ -0,0 +1,6 @@
+#!/bin/sh
+if [ -z "$XDG_VTNR" ]; then
+ exec /usr/bin/X -nolisten tcp "$@"
+else
+ exec /usr/bin/X -nolisten tcp -keeptty "$@" "vt$XDG_VTNR"
+fi
diff --git a/x11-apps/xinit/xinit-1.4.0-r1.ebuild b/x11-apps/xinit/xinit-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..13cf2917ed8c
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.4.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+ "${FILESDIR}/${PN}-1.4.0-startx-current-vt.patch"
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.2 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}