summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-13 16:51:16 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-13 16:54:23 -0600
commit9e116644445c0fc69553096b100980ee18d84053 (patch)
tree8d643e2c2542624b89c6b78ad956ab47e2e0df9d
parentdev-ruby/facter: 3.14.7 stable amd64 / x86 (diff)
downloadgentoo-9e116644445c0fc69553096b100980ee18d84053.tar.gz
gentoo-9e116644445c0fc69553096b100980ee18d84053.tar.bz2
gentoo-9e116644445c0fc69553096b100980ee18d84053.zip
dev-ruby/facter: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.14.6.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index 95c0bdbcefcd..f4bb14f30eae 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,2 +1 @@
-DIST facter-3.14.6.tar.gz 397339 BLAKE2B 74fae02a70194fd85789428c779f000e6b6750f52ecb0c713d6b772b3592a1974835367b148d046f849d61704adf82d93f519b86ecfe0007fb492f880a2aebca SHA512 6c17ba200fe82a2223b76505c29c6fb7bce2bff6e795316ea0b91d2fc8bc42bed9b930ba9c5d7b3851fd36fe93fb20e81a9cbc919589d4012e989234be1ba787
DIST facter-3.14.7.tar.gz 398902 BLAKE2B e399fba120bee70b85fb7ea39ba0f719efd6b6509add4000a4eb220aa0f59e1ffe7457a8959cbb81be78ace04ba9ef3038c39d2c975e8c0c6071cd22aa5aae78 SHA512 33c187844642645b4ad780c6a5be4af0d860fb824e70935d60eb626267cae46f00487ea408fab28149472c58e80c33bdb4585e6eec18f16d817b014c3f2bc675
diff --git a/dev-ruby/facter/facter-3.14.6.ebuild b/dev-ruby/facter/facter-3.14.6.ebuild
deleted file mode 100644
index f43caea884f4..000000000000
--- a/dev-ruby/facter/facter-3.14.6.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake-utils eutils ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.6-explicit-rspec-2.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake-utils_src_compile
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-}