summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-04-13 09:06:42 -0700
committerMatt Turner <mattst88@gentoo.org>2020-04-13 09:32:44 -0700
commita117c20f1b3127d4c397dddef4a7680359f1c9a3 (patch)
tree7c89f92b8c35cbdb1b6fe257bf77d14182820360
parentsys-kernel/vanilla-sources: Automated version bump to {4.19.115,5.5.17,5.6.4}... (diff)
downloadgentoo-a117c20f1b3127d4c397dddef4a7680359f1c9a3.tar.gz
gentoo-a117c20f1b3127d4c397dddef4a7680359f1c9a3.tar.bz2
gentoo-a117c20f1b3127d4c397dddef4a7680359f1c9a3.zip
media-libs/mesa: Revbump in order to rebuild against libdrm
And patch the libdrm version requirement so we don't have this problem again. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch33
-rw-r--r--media-libs/mesa/mesa-20.0.4-r1.ebuild (renamed from media-libs/mesa/mesa-20.0.4.ebuild)4
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch b/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
new file mode 100644
index 000000000000..09897526a65c
--- /dev/null
+++ b/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
@@ -0,0 +1,33 @@
+From 316b352e946a9993a20f28abc741d34455a957a8 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 13 Apr 2020 09:20:18 -0700
+Subject: [PATCH] meson: Specify the maximum required libdrm in dri.pc
+
+When dealing with a regression in libdrm-2.4.101, I masked the package
+in Gentoo. In doing so, we discovered that Mesa's dri.pc specifies a
+version requirement in dri.pc for >= the version of libdrm Mesa was
+built against, thus preventing packages from being rebuilt with the
+older version of libdrm installed.
+
+Let's reduce this version requirement to the latest libdrm required by
+Mesa instead, since libdrm is backward compatible.
+---
+ src/mesa/drivers/dri/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mesa/drivers/dri/meson.build b/src/mesa/drivers/dri/meson.build
+index acf7d2eb128..b09ca16e38a 100644
+--- a/src/mesa/drivers/dri/meson.build
++++ b/src/mesa/drivers/dri/meson.build
+@@ -86,7 +86,7 @@ endif
+ if with_dri
+ dri_req_private = []
+ if dep_libdrm.found()
+- dri_req_private = ['libdrm >= ' + dep_libdrm.version()]
++ dri_req_private = ['libdrm >= ' + _drm_ver]
+ endif
+
+ pkg.generate(
+--
+2.24.1
+
diff --git a/media-libs/mesa/mesa-20.0.4.ebuild b/media-libs/mesa/mesa-20.0.4-r1.ebuild
index 18accf194eda..a0d7a8ff5ca4 100644
--- a/media-libs/mesa/mesa-20.0.4.ebuild
+++ b/media-libs/mesa/mesa-20.0.4-r1.ebuild
@@ -246,6 +246,10 @@ x86? (
libglvnd? ( usr/lib/libGLX_mesa.so.0.0.0 )
)"
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
+)
+
llvm_check_deps() {
local flags=${MULTILIB_USEDEP}
if use video_cards_r600 || use video_cards_radeon || use video_cards_radeonsi