summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-28 14:58:39 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-28 14:59:36 +0100
commita233fec43988ab30d901ed3867379e297e63286a (patch)
tree1c8f16568478dcf40c2d37f68d832dff26e65ddb
parenteclass/portability.eclass: Make get_bmake return "bmake" on linux instead of ... (diff)
downloadgentoo-a233fec43988ab30d901ed3867379e297e63286a.tar.gz
gentoo-a233fec43988ab30d901ed3867379e297e63286a.tar.bz2
gentoo-a233fec43988ab30d901ed3867379e297e63286a.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.27
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.02.27.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index a941def4fbaf..1bf5e3a9ea28 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.02.13.tar.gz 1951048 SHA256 8bb5cb62aad23fd3b049d9ffac76af6d76af8c18d68da3a3b9f602adaca1d534 SHA512 5f453835e2829b74a1dce141180cfab33cb8e3ad8404f0b866495c7421d3e938a3ce374bcc7f4b11c52ac37e26a6e34692e7c147824f447e5f826253d32b1a47 WHIRLPOOL 132c175650f47fdf4d0b17a1c5d36b5dd1a183594193c328eb94eda58a6da6819689bb7fe732606e9c5f901ab3896a0a712f534cb29cf4355a925e9290441dc0
DIST youtube-dl-2016.02.22.tar.gz 1971515 SHA256 14cf17af94a23d451c1c8d2fcc8ee072ee99746d6bc7487c91043498599d630a SHA512 9b1e5bf5cfe8aef0dd55093c046669358b7efc01d0a89abd8a75a4f3dd132dec90b74f1e7bddadf22d4ea21a91168f4962752739c9acd9c232c6757c2307054c WHIRLPOOL 45690a4b1e1e0233d3217d481b9c078b3a4833eaa9857bc762eab4d2c6f663f7bcdbf7a1e065d52b555a6194572cff1e0bcafaf687381153f1e4c3b74c0da361
+DIST youtube-dl-2016.02.27.tar.gz 1982455 SHA256 fe22ed108ec94f35e66b0907edffc6e67af54ead95a6f71e4b1ac53d2e1e006e SHA512 cec7d1d3dea8276d8bf14f1f6892ee080fcb50aa2db86eeb06a3ac3e71035ce8168b2ededf57b5d10d66af4fd7d802efb8268baf1f6fc9e79b1f8bd663e8f498 WHIRLPOOL 607adfcc682bc2020f1262cd6128a8ea86c8ed3d7d9909f2f920e866ae5cd946b21aa68bfbcca1260c2b498f3dc19e2827c9504a9e7c2207fb690f682192af6b
diff --git a/net-misc/youtube-dl/youtube-dl-2016.02.27.ebuild b/net-misc/youtube-dl/youtube-dl-2016.02.27.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.02.27.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}