summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-11-26 23:05:46 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2016-11-27 00:59:12 -0500
commita24132e924d0b063156728403f2bd7756a1f5792 (patch)
treeeeb57d76206dae0c8a979ebd7d188bb379486563
parentnet-wireless/pyrit: bump to 0.5.0 (diff)
downloadgentoo-a24132e924d0b063156728403f2bd7756a1f5792.tar.gz
gentoo-a24132e924d0b063156728403f2bd7756a1f5792.tar.bz2
gentoo-a24132e924d0b063156728403f2bd7756a1f5792.zip
net-wireless/cpyrit-opencl: bump to 0.5.0
Package-Manager: portage-2.3.0
-rw-r--r--net-wireless/cpyrit-opencl/Manifest1
-rw-r--r--net-wireless/cpyrit-opencl/cpyrit-opencl-0.5.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/net-wireless/cpyrit-opencl/Manifest b/net-wireless/cpyrit-opencl/Manifest
index 8f18f47c2081..903beae94532 100644
--- a/net-wireless/cpyrit-opencl/Manifest
+++ b/net-wireless/cpyrit-opencl/Manifest
@@ -1 +1,2 @@
DIST cpyrit-opencl-0.4.0.tar.gz 22851 SHA256 aac593bce3f00ea7fd3d558083dbd7e168332a92736e51a621a0459d1bc042fa SHA512 105c735089c23850f46fc349d4393bc038ca676ed9437545af7d23d98786e52a6ed88a09eeb9b7e2ef3654eaa71e0172a64478f8a37177714b3060ad3af49e5a WHIRLPOOL 522311339e52e10eac4bb724e31e9b277dd831c85ad011121ea3e251a1314afdef45f518b4b47d1ad542b5b65a0f5abbeed47c6379b329fcc72aeded221041fe
+DIST pyrit-0.5.0.tar.gz 267614 SHA256 c610b7e5930e71ef466365418e58ce72f4b7dea5a3398c3296192f0c4a7175aa SHA512 912742cd7d9cd9231b9b3aa155a5170c0ba36c3865280423e100c1d12df34e093ee56305d8738d4f406abbfef9b1d540872872b8ef23d699466298d41289ad25 WHIRLPOOL ade13ce1f4835f3a9f1f31cd850ccc555c34c9a292c062d1444962ead3e3db3b35124cab58c14021468bee8da80072725cd5b90dd7913f63da6f86831b70b144
diff --git a/net-wireless/cpyrit-opencl/cpyrit-opencl-0.5.0.ebuild b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.5.0.ebuild
new file mode 100644
index 000000000000..6266b35243a4
--- /dev/null
+++ b/net-wireless/cpyrit-opencl/cpyrit-opencl-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A sub-package that adds OpenCL-capability to Pyrit"
+HOMEPAGE="https://github.com/JPaulMora/Pyrit"
+SRC_URI="https://github.com/JPaulMora/Pyrit/archive/v${PV}.tar.gz -> pyrit-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/openssl:=
+ sys-libs/zlib
+ virtual/opencl"
+RDEPEND="${DEPEND}"
+PDEPEND="~net-wireless/pyrit-${PV}"
+
+S="${WORKDIR}/Pyrit-${PV}/modules/cpyrit_opencl"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}