summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-11 01:28:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 14:03:15 +0100
commita2d112f5512cc3cb26f25a12085cc4be6ccc13f1 (patch)
tree32146bddbca1767051576fe1921c49381f0d830c
parentdev-qt: Fix build for QT5_MODULE=qtbase w/ GCC-11 (diff)
downloadgentoo-a2d112f5512cc3cb26f25a12085cc4be6ccc13f1.tar.gz
gentoo-a2d112f5512cc3cb26f25a12085cc4be6ccc13f1.tar.bz2
gentoo-a2d112f5512cc3cb26f25a12085cc4be6ccc13f1.zip
app-crypt/qca: Fix build with GCC-11
Closes: https://bugs.gentoo.org/764047 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-crypt/qca/files/qca-2.3.1-gcc11.patch30
-rw-r--r--app-crypt/qca/qca-2.3.1.ebuild7
2 files changed, 35 insertions, 2 deletions
diff --git a/app-crypt/qca/files/qca-2.3.1-gcc11.patch b/app-crypt/qca/files/qca-2.3.1-gcc11.patch
new file mode 100644
index 000000000000..cd4eaab86880
--- /dev/null
+++ b/app-crypt/qca/files/qca-2.3.1-gcc11.patch
@@ -0,0 +1,30 @@
+From f015cc64889035c084138864e2e030ece19c257b Mon Sep 17 00:00:00 2001
+From: Jeff Law <law@redhat.com>
+Date: Dec 04 2020 03:55:48 +0000
+Subject: Fix missing includes for gcc-11
+
+
+diff --git a/src/qca_cert.cpp b/src/qca_cert.cpp
+index 5e73d98..225aecd 100644
+--- a/src/qca_cert.cpp
++++ b/src/qca_cert.cpp
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#include <memory>
+ #include "qca_cert.h"
+
+ #include "qca_publickey.h"
+diff --git a/src/qca_default.cpp b/src/qca_default.cpp
+index fd35702..db87e87 100644
+--- a/src/qca_default.cpp
++++ b/src/qca_default.cpp
+@@ -19,6 +19,7 @@
+ *
+ */
+
++#include <memory>
+ #include "qca_core.h"
+
+ #include <QMutex>
diff --git a/app-crypt/qca/qca-2.3.1.ebuild b/app-crypt/qca/qca-2.3.1.ebuild
index b954f235e01f..4414a43132be 100644
--- a/app-crypt/qca/qca-2.3.1.ebuild
+++ b/app-crypt/qca/qca-2.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,7 +39,10 @@ DEPEND="${RDEPEND}
)
"
-PATCHES=( "${FILESDIR}/${PN}-disable-pgp-test.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-disable-pgp-test.patch"
+ "${FILESDIR}/${P}-gcc11.patch" # bug 764047
+)
qca_plugin_use() {
echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")