summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-03 00:23:11 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-03 00:24:00 +0000
commita37c22e60aa71752af57194b9231272b80e0d4ac (patch)
treedc1111c7364234f0534877ed3ca5ab089913e069
parentdev-erlang/jose: add 1.11.2 (diff)
downloadgentoo-a37c22e60aa71752af57194b9231272b80e0d4ac.tar.gz
gentoo-a37c22e60aa71752af57194b9231272b80e0d4ac.tar.bz2
gentoo-a37c22e60aa71752af57194b9231272b80e0d4ac.zip
sys-auth/yubico-piv-tool: add 2.3.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-auth/yubico-piv-tool/Manifest1
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-2.3.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/Manifest b/sys-auth/yubico-piv-tool/Manifest
index f2a0fe19e931..a255bd8c44b4 100644
--- a/sys-auth/yubico-piv-tool/Manifest
+++ b/sys-auth/yubico-piv-tool/Manifest
@@ -1 +1,2 @@
DIST yubico-piv-tool-2.2.1.tar.gz 1310253 BLAKE2B f5e5d2c351200b2fc57aafdd02a604ee5f15cd8f1a0cb552133a367da2cbf7fe248ec9eba649427b30e8322126be1f9677fd471b38db1f00cda37ccb0ac413c9 SHA512 495a269194d8d9d8957542611959b3fc8e0ae54d1cab5c041f2604590cc740e89e0956b9d595f8a06f138e92b8804def52aae797f199479a81fc1fc3d57bfb96
+DIST yubico-piv-tool-2.3.0.tar.gz 1329085 BLAKE2B b084982139012b4993a023078fd8ce7c106cb5c1e71475f26398012b86fc65e985a7c51300b3b122884e35327293737ed48b31bfdc83326dda9c9c05f2eb984d SHA512 72125df922e32322563e95286e04d19e56db9c6e66ae9003ae7dfffac47425b8b2bc7c71ecfa603f96f3a24c985fca1f436580dc579ff44196dcde7aeceee7f3
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.3.0.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.3.0.ebuild
new file mode 100644
index 000000000000..94648193eb08
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Command-line tool and p11-kit module for the YubiKey PIV application"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/pcsc-lite
+ dev-libs/openssl:=[-bindist(-)]"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+BDEPEND="dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.1-tests-optional.patch
+ "${FILESDIR}"/${PN}-2.1.1-ykcs11-threads.patch
+ "${FILESDIR}"/${PN}-2.3.0-no-Werror.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIB=OFF
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ echo "module: ${EPREFIX}/usr/$(get_libdir)/libykcs11.so" > ${PN}.module \
+ || die "Failed to generate p11-kit module configuration"
+ insinto /usr/share/p11-kit/modules
+ doins ${PN}.module
+}