summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-06 03:47:38 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-06 03:47:38 +0100
commita3c3ac659b99533c6fdf0795a94cfd3583deb3b3 (patch)
treec6dac2752b6fee0d66905efd75285e00be7441ec
parentdev-util/checkbashisms: Removed old. (diff)
downloadgentoo-a3c3ac659b99533c6fdf0795a94cfd3583deb3b3.tar.gz
gentoo-a3c3ac659b99533c6fdf0795a94cfd3583deb3b3.tar.bz2
gentoo-a3c3ac659b99533c6fdf0795a94cfd3583deb3b3.zip
dev-libs/libinput: Bump to version 1.6.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.6.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 4363424fb764..9378439bd9e4 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,4 @@
DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f070f8863393d6fb7ca4c68e451 SHA512 ecd1ddc737b8207d9e494f809340e2c0ac2927db80cf4c325ba12fb84387138d0128df7e841c87feafe425d6382f87f123f28531f7045fbcdd1176559895b79b WHIRLPOOL 99f18e00e2a4a284b7995f677053501989b526e16f41e508023638a1c0e660940d0cb991f399480a30a49073063aab1651e52bdea7861266300d9db885806ac4
DIST libinput-1.5.4.tar.xz 927448 SHA256 6f9ad1ede468bd54ec4469b8a4eb93a6f62f7fe6480c7a43e36c5d58cc2822b7 SHA512 114f436806fd27ece2b19577eefd3f6299cc88612f8437fd07ba1862c0bf4347ac5cc09fad9f798a5e242abd176cfb271fa52af04b0ef88da3210a96fd57a086 WHIRLPOOL d7c2ffd8212c4808641b65f553ea6c1553188a30279f8e3491767a8ba159d42dbd30a0cebc3a727542a83cf216c17d1b5f1504dc8fbb4f7b5664aac35b8032dc
DIST libinput-1.6.0.tar.xz 927656 SHA256 b7534f518d735c643aedca2fb4694683dfddc8d0600cfb628c87a18e65255832 SHA512 0e52f70fc5b1aa1e9c0621770ba2530f1652611aff1a557ac8083559e22293942d7c468f9bafe9e97e4f71e71df6f3828f9949d8897bea26982045340e3edc92 WHIRLPOOL b41858d727eb27dbcd4025212731fe93e3970f7d36e8654bc5b121b3a6a3d6c1ca6117750d02b54db908d118d1b84a0eec5581b88a517635ffece5fb1378dae2
+DIST libinput-1.6.1.tar.xz 926988 SHA256 9d816f13eee63bcca0e9c3bb652c52ab55f39be4d1b90b54e4bfd1dc92ef55a8 SHA512 b18fdbfa58c14d6a5d183da3c1097d31f7dd9cce41ea69ddfa0bbd1bf8572aaa8e1ecaacdc30e3cc5e21cd320ea106ec86800a24e8f571bce61a02ddc7d43511 WHIRLPOOL bf7ca3c5968827fd73592f56d1e3a1c7897b1bd12fc431e98550ad36aa147f4c39ccb41092ef84d0cb739960c53bfa1b3a62cf7f30fdf7a77da90ba91e6db96e
diff --git a/dev-libs/libinput/libinput-1.6.1.ebuild b/dev-libs/libinput/libinput-1.6.1.ebuild
new file mode 100644
index 000000000000..8d94336aa1da
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ default
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}