summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-14 14:35:16 +0000
committerSam James <sam@gentoo.org>2021-01-14 14:35:17 +0000
commita3f975f9e8d12ee52aea1233491d4255739d171e (patch)
tree6255ac8396d96f1a58de7a4108d6531a7d067abc
parentgames-strategy/warzone2100: re-sort options (diff)
downloadgentoo-a3f975f9e8d12ee52aea1233491d4255739d171e.tar.gz
gentoo-a3f975f9e8d12ee52aea1233491d4255739d171e.tar.bz2
gentoo-a3f975f9e8d12ee52aea1233491d4255739d171e.zip
games-action/clanbomber: bump to 2.2.0
Closes: https://bugs.gentoo.org/677624 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-action/clanbomber/Manifest1
-rw-r--r--games-action/clanbomber/clanbomber-2.2.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/games-action/clanbomber/Manifest b/games-action/clanbomber/Manifest
index d303fa2b472f..9a49655f9a05 100644
--- a/games-action/clanbomber/Manifest
+++ b/games-action/clanbomber/Manifest
@@ -1 +1,2 @@
DIST clanbomber-2.1.1.tar.lzma 2070392 BLAKE2B ba6e183a5469a30949a4441f9f40df8f87271c741110ddcc17f584f0f59564a041e5b74214b53ccddbae7df46ffc573a866e1089db0a782e7c73dda1c2d4ac6f SHA512 b2d634c20d60cd7c080263a8ebea931bd623342c32380494c0076441021719135ca7861e0467e0c71cd46bb4ed85d3ce364dbfa2c8399eaf058f62f294a21c32
+DIST clanbomber-2.2.0.tar.xz 2118672 BLAKE2B fd384d01552231fb3d823b07a1248c6ca0d1c5bb5f7f8d7dae3a71387d457d789c2dfabb69817233fac95699b9bd96e52846e736de8c55735bb67be7edb5b158 SHA512 307921d118286dcfd29ce96e0a35dfdc389dae6bd71a7dfd088311f611a75b167c1018542b5dc59c26bfb808a985011f6691c297cc8dd472da0fe5e005a401d5
diff --git a/games-action/clanbomber/clanbomber-2.2.0.ebuild b/games-action/clanbomber/clanbomber-2.2.0.ebuild
new file mode 100644
index 000000000000..4458ddf64950
--- /dev/null
+++ b/games-action/clanbomber/clanbomber-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Bomberman-like multiplayer game"
+HOMEPAGE="https://savannah.nongnu.org/projects/clanbomber/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ dev-libs/boost:=
+ media-fonts/dejavu
+ media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog ChangeLog.hg IDEAS NEWS QUOTES README TODO )
+
+src_prepare() {
+ default
+ sed -i -e 's/menuentry//' src/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon src/pics/cup2.png ${PN}.png
+ make_desktop_entry ${PN}2 ClanBomber2
+
+ rm "${ED}/usr/share/${PN}/fonts/DejaVuSans-Bold.ttf" || die
+ dosym ../../fonts/dejavu/DejaVuSans-Bold.ttf \
+ /usr/share/${PN}/fonts/DejaVuSans-Bold.ttf
+}