summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-03 09:14:49 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-03 09:17:32 +0200
commita4f596f6ebd34aad7bad26ce8887c10a30b63f00 (patch)
treed12b239b89f0b5a1a5116a75370fded1f79379dd
parentdev-ruby/asciimath: add 1.0.5 (diff)
downloadgentoo-a4f596f6ebd34aad7bad26ce8887c10a30b63f00.tar.gz
gentoo-a4f596f6ebd34aad7bad26ce8887c10a30b63f00.tar.bz2
gentoo-a4f596f6ebd34aad7bad26ce8887c10a30b63f00.zip
dev-ruby/selenium-webdriver: add 3.14.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-ruby/selenium-webdriver/Manifest1
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-3.14.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index 6ba3e3a7b6d9..2214a5e87cb1 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -3,3 +3,4 @@ DIST selenium-webdriver-3.10.0.gem 841728 BLAKE2B fb36121b835c7750595cd57c3217c2
DIST selenium-webdriver-3.12.0.gem 843264 BLAKE2B f9a2e233658e071144f153f7710ec15cd58d8831793f7212d1d49a76d08d80c7110bcf1afc86e98210c6753d19ab2c63f169754f148db8a994fb777048c10b6d SHA512 1d5a510e3e7775c6b8c960de8a5f0ae2084f490c17084e8ba0894dc32021c9295c9301c6bf0ba07e0e9827a8d99ac9f9c5d29fbf57425a076825fe18e4a8f88f
DIST selenium-webdriver-3.13.0.gem 843264 BLAKE2B cce9be238d5b6480635ed286893f4b72e26166c21fd07ba99e2c008fd7360f0f3744dba24d015aa92612775a8c726616f391b1681d4a37689933a6b9b08d41f3 SHA512 e0b7d521ba748bbb224d659b56b9b4ff9970aab84b827eac1b755d950ad840b70a09567190e5ebafd1a513bb0c4cbfcc25e6a6e4a83051df951237533453ec44
DIST selenium-webdriver-3.13.1.gem 843776 BLAKE2B 633a6582f9294f008a77d74454a208bb67425f5a790e97a59323b51bbd3d6b9f28c611cbfb72bb922898c353fb35812b99529a75230ebfb1da18683378d36740 SHA512 b372a5af0380adb607e3f9ba24713cc8ef288e1432c2c6ea71426b8f5f96b315aace36283d585cc75546b467572822f0eab3d8217702d1b6d2ec303c59c0b98f
+DIST selenium-webdriver-3.14.0.gem 844288 BLAKE2B 52c4a4cd4f4b939d685efd764a0ede064dd31713804ccbbfbb0b92b51c39c4f3eda7529c46ab795cf1e02b27d8e32309fc89801765d9542cb0df2145fd1a0b86 SHA512 81600fbc8c033e649127c21721431d7c60f17a729f21012355d4e6b866eaa22324514e813b94e9677c49f313f00afaced205fddee14756eb2fa3f1ee68cd992c
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-3.14.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-3.14.0.ebuild
new file mode 100644
index 000000000000..eb794075ddf1
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-3.14.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0
+ >=dev-ruby/rubyzip-1.2:1"