summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 19:19:18 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 19:35:01 +0200
commita6861bc62c00370af922fa1702366443ff9130d5 (patch)
treea62c06d006040b0645e2dc12424dedc78e049ff2
parentdev-python/cryptography: add libressl support (diff)
downloadgentoo-a6861bc62c00370af922fa1702366443ff9130d5.tar.gz
gentoo-a6861bc62c00370af922fa1702366443ff9130d5.tar.bz2
gentoo-a6861bc62c00370af922fa1702366443ff9130d5.zip
dev-python/python-sipsimple: add libressl support
-rw-r--r--dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild b/dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..f3e5e3ceee29
--- /dev/null
+++ b/dev-python/python-sipsimple/python-sipsimple-2.5.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/SipClient/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="libressl"
+
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-db/sqlite:3
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-python/python-application[${PYTHON_USEDEP}]
+ media-libs/alsa-lib
+ media-libs/libv4l
+ media-libs/libvpx
+ sys-apps/util-linux
+ virtual/ffmpeg
+"
+RDEPEND="${CDEPEND}
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/python-cjson[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-eventlib[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/python-gnutls[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-msrplib[${PYTHON_USEDEP}]
+ dev-python/python-xcaplib[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"