summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-28 09:37:44 +0200
committerJeroen Roovers <jer@gentoo.org>2018-03-28 09:38:02 +0200
commita76cf22ed5425bf22596c355516fd9e1b6402bfb (patch)
treeab34fdbadc65a39e88480243727ac890e3a5beb7
parentdev-perl/XML-SAX-Writer: Bump to version 0.570.0 (diff)
downloadgentoo-a76cf22ed5425bf22596c355516fd9e1b6402bfb.tar.gz
gentoo-a76cf22ed5425bf22596c355516fd9e1b6402bfb.tar.bz2
gentoo-a76cf22ed5425bf22596c355516fd9e1b6402bfb.zip
sys-apps/xinetd: Version 2.3.15.3.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-apps/xinetd/Manifest1
-rw-r--r--sys-apps/xinetd/xinetd-2.3.15.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/xinetd/Manifest b/sys-apps/xinetd/Manifest
index 675318530179..79afac57ab64 100644
--- a/sys-apps/xinetd/Manifest
+++ b/sys-apps/xinetd/Manifest
@@ -1 +1,2 @@
+DIST xinetd-2.3.15.3.tar.xz 383204 BLAKE2B dada7e1efb8c70d9b47efbb33de54e643e195fc043a2fe8b1b61a1d9e597a5a10feda8d6692e665af1f1690870e619098a9a2367df3a73f7821a91777532f1fa SHA512 3a744d5ce66da46743eec28d5b95a44709b1828187078984e59d7220ac325abce1198927e9156f343a4e16a9dc63e8846f1dcb0facbf05ea44c73aecbe7e504f
DIST xinetd-2.3.15.tar.gz 309774 BLAKE2B b5c933a2aa7a2ef4a2d58b53890f04569fe592005c646f39a00d4716325c8ac9b9aa3b8b4b2f2b861430c8415167ab1d394de3d3b4bd761239c5223b1d2b0419 SHA512 9d6fee1fbc90329629d84086ae7de5cd51c25af7b68e52aa704d6f74bee5f0e3d54ca1bcf780f90f74ddc8d336ae0abb5e5e368d43c426a26b8dd2c4676d26aa
diff --git a/sys-apps/xinetd/xinetd-2.3.15.3.ebuild b/sys-apps/xinetd/xinetd-2.3.15.3.ebuild
new file mode 100644
index 000000000000..39c76db8e114
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.15.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="https://github.com/openSUSE/xinetd"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="perl rpc selinux tcpd"
+
+DEPEND="
+ selinux? ( sys-libs/libselinux )
+ rpc? ( net-libs/libtirpc:= )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+"
+RDEPEND="
+ ${DEPEND}
+ perl? ( dev-lang/perl )
+"
+DEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ find -name Makefile.in -exec sed -i 's:\<ar\>:$(AR):' {} +
+}
+
+src_configure() {
+ tc-export AR PKG_CONFIG
+ if use rpc ; then
+ append-cflags $(${PKG_CONFIG} --cflags libtirpc)
+ else
+ append-cppflags -DNO_RPC
+ export ac_cv_header_{rpc_{rpc,rpcent,pmap_clnt},netdb}_h=no
+ fi
+ LIBS=$(${PKG_CONFIG} --libs libtirpc) \
+ econf \
+ $(use_with tcpd libwrap) \
+ $(use_with selinux labeled-networking) \
+ --with-loadavg
+}
+
+src_install() {
+ default
+
+ use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+ newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+ newconfd "${FILESDIR}"/xinetd.confd xinetd
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+ dodoc README.md CHANGELOG
+}