summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 02:29:08 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:17:58 +0100
commita7baf149ced14da8029854356a0218055dc98ded (patch)
tree4997ac7ffb82cd7e1a039d5cbee4bd651d52e92f
parentgames-fps/ezquake-bin: port to EAPI 7, games.eclass-- (diff)
downloadgentoo-a7baf149ced14da8029854356a0218055dc98ded.tar.gz
gentoo-a7baf149ced14da8029854356a0218055dc98ded.tar.bz2
gentoo-a7baf149ced14da8029854356a0218055dc98ded.zip
games-roguelike/FTL: port to EAPI 7, games.eclass--
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-roguelike/FTL/FTL-1.5.13-r1.ebuild (renamed from games-roguelike/FTL/FTL-1.5.13.ebuild)33
1 files changed, 18 insertions, 15 deletions
diff --git a/games-roguelike/FTL/FTL-1.5.13.ebuild b/games-roguelike/FTL/FTL-1.5.13-r1.ebuild
index 41455eb7e7b3..d0eb80d7dba2 100644
--- a/games-roguelike/FTL/FTL-1.5.13.ebuild
+++ b/games-roguelike/FTL/FTL-1.5.13-r1.ebuild
@@ -1,18 +1,20 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils games
+inherit desktop wrapper
DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
HOMEPAGE="http://www.ftlgame.com/"
SRC_URI="FTL.${PV}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT bundled-libs? ( FTL LGPL-2.1 ZLIB libpng )"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="bundled-libs"
+
RESTRICT="fetch bindist splitdebug"
RDEPEND="
@@ -23,12 +25,13 @@ RDEPEND="
media-libs/freetype:2
media-libs/libsdl[X,sound,joystick,opengl,video]
sys-libs/zlib
- )"
-
-QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/bin/${PN}
- ${GAMES_PREFIX_OPT#/}/${PN}/lib/*"
+ )
+"
-S=${WORKDIR}/${PN}
+QA_PREBUILT="
+ opt/${PN}/bin/${PN}
+ opt/${PN}/lib/*
+"
pkg_nofetch() {
einfo "Please buy & download ${SRC_URI} from:"
@@ -45,21 +48,21 @@ src_prepare() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
+ local dir=opt/${PN}
- insinto "${dir}"
+ insinto ${dir}
doins -r data/resources
- exeinto "${dir}"/bin
+ exeinto ${dir}/bin
doexe data/${ARCH}/bin/${PN}
- exeinto "${dir}"/lib
+ exeinto ${dir}/lib
doexe data/${ARCH}/lib/*.so*
- games_make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
newicon data/resources/exe_icon.bmp FTL.bmp
- dohtml ${PN}_README.html
- prepgamesdirs
+ docinto html
+ dodoc ${PN}_README.html
}