summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-01-23 20:19:01 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-23 20:19:01 +0100
commita7efcbfd43bb021002c7dbe557270994a770b61d (patch)
treee6e9d9b5ec7c370fbdb42dda9433ea41bd6a7db1
parentx11-wm/icewm: Revbump to fix application menu issue (diff)
downloadgentoo-a7efcbfd43bb021002c7dbe557270994a770b61d.tar.gz
gentoo-a7efcbfd43bb021002c7dbe557270994a770b61d.tar.bz2
gentoo-a7efcbfd43bb021002c7dbe557270994a770b61d.zip
media-libs/libsamplerate: Version bump to 0.2.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-libs/libsamplerate/Manifest1
-rw-r--r--media-libs/libsamplerate/libsamplerate-0.2.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/libsamplerate/Manifest b/media-libs/libsamplerate/Manifest
index e0b66cdf10c1..31f284bb59ba 100644
--- a/media-libs/libsamplerate/Manifest
+++ b/media-libs/libsamplerate/Manifest
@@ -1,2 +1,3 @@
DIST libsamplerate-0.1.9.tar.gz 4336641 BLAKE2B f1cf4c669315ef6a93bfa0c5c73284187068b9b049299afbfd45da5c133372cfd6fdd00fda2dbb2a6740446219203ceda8b46385c844d9ef480e8578aa0b3928 SHA512 78596657963cbf06785e3e6e1190b093df71da52ca340e75bd8246a962cd79dd1c90fa5527c607cebcb296e2c1ee605015278b274e3b768f2f3fbeb0eadfb728
DIST libsamplerate-0.2.0.tar.bz2 3739932 BLAKE2B 45e7d1ceb4134bf41117ba09c3280e403d66b928bd0528cf2bae0c43064bc032de18d426f93802cd484080bc5b49b8df6378ea023c0ce76381d0a6d3972d8128 SHA512 40422f8a9a5eaf1d0cfa18a98ad561885c15556962db8892c412870745774f971087f5fc4775bc6e462857162ff7ba895d5b55e3cea9982aebdb915de391699d
+DIST libsamplerate-0.2.1.tar.bz2 3747188 BLAKE2B 83540f3e75cfa79cbd166f075d22cab6a63e0e057b90ac6a3760c07196cac962df7d1ca26620a9033de046e0528bee3ded2b482e8629b1ae316844b5b31f3074 SHA512 f54f7f12c9536868d7a11fc9cbb86857505e7b75fe34cedaf0b9bfc864da6037296b3eae303a33d4c87b7fd20d96933b91ef59c8cc3d1313b9fc21654e5daa2d
diff --git a/media-libs/libsamplerate/libsamplerate-0.2.1.ebuild b/media-libs/libsamplerate/libsamplerate-0.2.1.ebuild
new file mode 100644
index 000000000000..c2eb013b6fe2
--- /dev/null
+++ b/media-libs/libsamplerate/libsamplerate-0.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Secret Rabbit Code (aka libsamplerate) is a Sample Rate Converter for audio"
+HOMEPAGE="http://libsndfile.github.io/libsamplerate/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libsndfile/libsamplerate.git"
+else
+ SRC_URI="https://github.com/libsndfile/libsamplerate/releases/download/${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Alsa/FFTW are only required for tests
+# libsndfile is only used by examples and tests
+DEPEND="
+ test? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/libsndfile[${MULTILIB_USEDEP}]
+ sci-libs/fftw:3.0[${MULTILIB_USEDEP}]
+ )"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ $(use_enable test alsa) \
+ $(use_enable test fftw) \
+ $(use_enable test sndfile)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
+}