summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 11:41:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 13:11:05 +0100
commita875265aa86b5f6eaf7af0fe2d0f8844b23dbb8d (patch)
tree3be532afe308fd9e6ff64d98c73fc4d4db1dbe1b
parentsys-apps/help2man: Bump to version 1.47.12 (diff)
downloadgentoo-a875265aa86b5f6eaf7af0fe2d0f8844b23dbb8d.tar.gz
gentoo-a875265aa86b5f6eaf7af0fe2d0f8844b23dbb8d.tar.bz2
gentoo-a875265aa86b5f6eaf7af0fe2d0f8844b23dbb8d.zip
*/*: Switch gnome proj to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libgit2/libgit2-0.28.4.ebuild8
-rw-r--r--gui-libs/libwpe/libwpe-1.4.0.1.ebuild6
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.4.0.ebuild6
3 files changed, 10 insertions, 10 deletions
diff --git a/dev-libs/libgit2/libgit2-0.28.4.ebuild b/dev-libs/libgit2/libgit2-0.28.4.ebuild
index 48c712484567..c88d84762df8 100644
--- a/dev-libs/libgit2/libgit2-0.28.4.ebuild
+++ b/dev-libs/libgit2/libgit2-0.28.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -46,7 +46,7 @@ src_configure() {
-DUSE_SSH=$(usex ssh)
-DTHREADSAFE=$(usex threads)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -56,12 +56,12 @@ src_test() {
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
- cmake-utils_src_test -R offline
+ cmake_src_test -R offline
fi
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc docs/*.{md,txt}
if use examples ; then
diff --git a/gui-libs/libwpe/libwpe-1.4.0.1.ebuild b/gui-libs/libwpe/libwpe-1.4.0.1.ebuild
index c499b99ae51b..402fdf1db442 100644
--- a/gui-libs/libwpe/libwpe-1.4.0.1.ebuild
+++ b/gui-libs/libwpe/libwpe-1.4.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
HOMEPAGE="https://wpewebkit.org/"
@@ -29,5 +29,5 @@ src_configure() {
-DBUILD_DOCS=OFF # hotdoc not packaged
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.4.0.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.4.0.ebuild
index 86b60c4026f6..062bcbc68fa9 100644
--- a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.4.0.ebuild
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="WPE backend designed for Linux desktop systems"
HOMEPAGE="https://wpewebkit.org/"
@@ -35,5 +35,5 @@ src_configure() {
-DBUILD_DOCS=OFF # hotdoc not packaged
)
- cmake-utils_src_configure
+ cmake_src_configure
}