summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-20 01:22:37 +0100
committerSam James <sam@gentoo.org>2022-06-29 08:39:44 +0000
commita988da45ce12d8bf2e47c47dfd775ef4dee49620 (patch)
tree2fc19d658bf365802bbc3c1125df794fb94ea3b1
parentsys-fs/inotify-tools: adopt (diff)
downloadgentoo-a988da45ce12d8bf2e47c47dfd775ef4dee49620.tar.gz
gentoo-a988da45ce12d8bf2e47c47dfd775ef4dee49620.tar.bz2
gentoo-a988da45ce12d8bf2e47c47dfd775ef4dee49620.zip
app-admin/apache-tools: drop which dependency
Closes: https://bugs.gentoo.org/844868 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.54-r1.ebuild108
-rw-r--r--app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch54
2 files changed, 162 insertions, 0 deletions
diff --git a/app-admin/apache-tools/apache-tools-2.4.54-r1.ebuild b/app-admin/apache-tools/apache-tools-2.4.54-r1.ebuild
new file mode 100644
index 000000000000..8b3560d27cf2
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.4.54-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="https://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc64-solaris ~x64-solaris"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/apr-1.5.0:1=
+ dev-libs/apr-util:1=
+ dev-libs/expat
+ dev-libs/libpcre
+ virtual/libcrypt:=
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/httpd-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.7-Makefile.patch" #459446
+ "${FILESDIR}/${PN}-2.4.54-no-which.patch" #844868
+)
+
+src_prepare() {
+ default
+
+ # This package really should upgrade to using pcre's .pc file.
+ cat <<-\EOF >"${T}"/pcre-config
+ #!/bin/bash
+ flags=()
+ for flag; do
+ if [[ ${flag} == "--version" ]]; then
+ flags+=( --modversion )
+ else
+ flags+=( "${flag}" )
+ fi
+ done
+ exec ${PKG_CONFIG} libpcre "${flags[@]}"
+ EOF
+ chmod a+x "${T}"/pcre-config || die
+
+ # Only here for which patch
+ eautoreconf
+}
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ tc-export PKG_CONFIG
+
+ local myeconfargs=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules
+ --sbindir="${EPREFIX}"/usr/sbin
+ --with-z="${EPREFIX}"/usr
+ --with-apr="${ESYSROOT}"/usr
+ --with-apr-util="${ESYSROOT}"/usr
+ --with-pcre="${T}"/pcre-config
+ $(use_enable ssl)
+ $(usex ssl '--with-ssl="${EPREFIX}"/usr' '')
+ )
+ # econf overwrites the stuff from config.layout.
+ ac_cv_path_PKGCONFIG="${PKG_CONFIG}" \
+ econf "${myeconfargs[@]}"
+ sed -i \
+ -e '/^LTFLAGS/s:--silent::' \
+ build/rules.mk build/config_vars.mk || die
+}
+
+src_compile() {
+ emake -C support
+}
+
+src_install() {
+ emake -C support DESTDIR="${D}" install
+ dodoc CHANGES
+ doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
+ docs/man/{htcacheclean,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${ED}"/usr/sbin >/dev/null || die
+ local i
+ for i in *; do
+ dosym ${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym ab /usr/bin/ab-ssl
+ dosym ab /usr/bin/ab2-ssl
+ fi
+}
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch b/app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch
new file mode 100644
index 000000000000..65764dfe022a
--- /dev/null
+++ b/app-admin/apache-tools/files/apache-tools-2.4.54-no-which.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/844868
+https://bz.apache.org/bugzilla/show_bug.cgi?id=66130
+--- a/build/aix/buildaix.ksh
++++ b/build/aix/buildaix.ksh
+@@ -26,14 +26,14 @@ export CFLAGS='-O2 -qlanglvl=extc99'
+ lslpp -L bos.adt.insttools >/dev/null
+ [[ $? -ne 0 ]] && echo "must have bos.adt.insttools installed" && exit -1
+
+-apr_config=`which apr-1-config`
+-apu_config=`which apu-1-config`
++apr_config=`command -v apr-1-config 2>/dev/null`
++apu_config=`command -v apu-1-config 2>/dev/null`
+
+ if [[ -z ${apr_config} && -z ${apu_config} ]]
+ then
+ export PATH=/opt/bin:${PATH}
+- apr_config=`which apr-1-config`
+- apu_config=`which apu-1-config`
++ apr_config=`command -v apr-1-config 2>/dev/null`
++ apu_config=`command -v apu-1-config 2>/dev/null`
+ fi
+
+ while test $# -gt 0
+--- a/build/pkg/buildpkg.sh
++++ b/build/pkg/buildpkg.sh
+@@ -24,8 +24,8 @@ PREFIX=/usr/local/apache2
+ TEMPDIR=/var/tmp/$USER/httpd-root
+ rm -rf $TEMPDIR
+
+-apr_config=`which apr-1-config`
+-apu_config=`which apu-1-config`
++apr_config=`command -v apr-1-config 2>/dev/null`
++apu_config=`command -v apu-1-config 2>/dev/null`
+
+ while test $# -gt 0
+ do
+--- a/configure.in
++++ b/configure.in
+@@ -216,13 +216,13 @@ AC_ARG_WITH(pcre,
+ APACHE_HELP_STRING(--with-pcre=PATH,Use external PCRE library))
+ if test "x$with_pcre" = "x" || test "$with_pcre" = "yes"; then
+ with_pcre="$PATH"
+-else if which $with_pcre 2>/dev/null; then :; else
++else if command -v $with_pcre 2>/dev/null; then :; else
+ with_pcre="$with_pcre/bin:$with_pcre"
+ fi
+ fi
+
+ AC_CHECK_TARGET_TOOLS(PCRE_CONFIG, [pcre2-config pcre-config],
+- [`which $with_pcre 2>/dev/null`], $with_pcre)
++ [`command -v $with_pcre 2>/dev/null`], $with_pcre)
+
+ if test "x$PCRE_CONFIG" != "x"; then
+ if $PCRE_CONFIG --version >/dev/null 2>&1; then :; else