summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 15:06:32 +0000
committerSam James <sam@gentoo.org>2021-03-16 15:06:49 +0000
commita9dfcd0754e2988c0cc78b996238c2d7d429d8a1 (patch)
treef9c5982775337f467b20cd02bf53a60dca842584
parentsys-apps/acl: Bump to version 2.3.1 (diff)
downloadgentoo-a9dfcd0754e2988c0cc78b996238c2d7d429d8a1.tar.gz
gentoo-a9dfcd0754e2988c0cc78b996238c2d7d429d8a1.tar.bz2
gentoo-a9dfcd0754e2988c0cc78b996238c2d7d429d8a1.zip
media-gfx/zbar: add autoconf 2.70 patch
Closes: https://bugs.gentoo.org/775656 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/zbar/files/zbar-0.23.1-autoconf-2.70.patch38
-rw-r--r--media-gfx/zbar/zbar-0.23.1.ebuild5
2 files changed, 41 insertions, 2 deletions
diff --git a/media-gfx/zbar/files/zbar-0.23.1-autoconf-2.70.patch b/media-gfx/zbar/files/zbar-0.23.1-autoconf-2.70.patch
new file mode 100644
index 000000000000..be9547ead111
--- /dev/null
+++ b/media-gfx/zbar/files/zbar-0.23.1-autoconf-2.70.patch
@@ -0,0 +1,38 @@
+https://github.com/mchehab/zbar/commit/89e7900d85dd54ef351a7ed582aec6a5a5d7fa37
+https://bugs.gentoo.org/775656
+
+From 89e7900d85dd54ef351a7ed582aec6a5a5d7fa37 Mon Sep 17 00:00:00 2001
+From: Boyuan Yang <byang@debian.org>
+Date: Thu, 31 Dec 2020 12:56:26 -0500
+Subject: [PATCH] configure.ac: Fix quote issue (autoconf 2.70 compat)
+
+One of the AS_IF() macro was not properly quoted. This commit
+fixes that issue.
+
+This patch closes: #132 (fixes this bug report).
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index df0220a8..db4bc902 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -656,7 +656,7 @@ AS_IF([test "x$with_qt" != "xno"],
+ [with_qt="no"])])])
+
+ AS_IF([test "x$with_qt" != "xno"],
+- AS_IF([test "x$with_qt5" != "xno"],
++ [AS_IF([test "x$with_qt5" != "xno"],
+ [AC_CHECK_PROGS(MOC, [moc-qt5 moc])
+ AC_MSG_NOTICE([using moc from $MOC])
+ QT_VERSION=`$PKG_CONFIG Qt5Gui --modversion`
+@@ -672,7 +672,7 @@ dnl -fPIC has no effect on Windows and breaks windres
+ QT_VERSION=`$PKG_CONFIG QtGui --modversion`
+ AC_MSG_NOTICE([using Qt version $QT_VERSION])
+ qt_pkgconfig_file="zbar-qt.pc"
+- ]))
++ ])])
+
+ AM_CONDITIONAL([HAVE_QT], [test "x$with_qt" = "xyes"])
+
diff --git a/media-gfx/zbar/zbar-0.23.1.ebuild b/media-gfx/zbar/zbar-0.23.1.ebuild
index 2f529efbe041..d74a878a969a 100644
--- a/media-gfx/zbar/zbar-0.23.1.ebuild
+++ b/media-gfx/zbar/zbar-0.23.1.ebuild
@@ -84,8 +84,9 @@ PATCHES=(
"${FILESDIR}/${P}_fix_leftover_on_shell_compatibility.patch"
"${FILESDIR}/${P}_fix_unittest.patch"
"${FILESDIR}/${P}_musl_include_locale_h.patch"
- "${FILESDIR}/zbar-0.23_fix_Qt5X11Extras_detect.patch"
- "${FILESDIR}/zbar-0.23_fix_python_detect.patch"
+ "${FILESDIR}/${PN}-0.23_fix_Qt5X11Extras_detect.patch"
+ "${FILESDIR}/${PN}-0.23_fix_python_detect.patch"
+ "${FILESDIR}/${P}-autoconf-2.70.patch"
)
DOCS=( README.md NEWS.md TODO.md HACKING.md TODO.md ChangeLog )