summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 09:31:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 09:38:59 +0100
commitaa3490337b817dc89150796df6d5f982a85adbf9 (patch)
tree22b1d117162ed0489ba59e32c5ad07eb68ebe97f
parentprofiles/package.mask: drop masks for removed packages (diff)
downloadgentoo-aa3490337b817dc89150796df6d5f982a85adbf9.tar.gz
gentoo-aa3490337b817dc89150796df6d5f982a85adbf9.tar.bz2
gentoo-aa3490337b817dc89150796df6d5f982a85adbf9.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index c9cf8ef692ea..15ca04eb80ab 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1 +1,2 @@
DIST xfce4-screenshooter-1.9.7.tar.bz2 536583 BLAKE2B de6376b68a7936f7ea22762449389ddd8ae1bf29f5fb062054691e4dc3f19471b63ef6201e813624cf2ec34c565ec0ac0d1de9db7d1b86296c736def5ab5023e SHA512 364594bd00172f0becb85f8643e4106b4a7b71ac5dad765850f54de011a77175801bd9e7eaab6a8bbb3b1353299fdfa25cc0a4a52d49017f9b51330377eb9add
+DIST xfce4-screenshooter-1.9.8.tar.bz2 562481 BLAKE2B b0e644cdbc7a9a237eec1aec39b9a3b2ebc67f8241f4ff5f828174011eb8bb37a231e9c9f91ccbab7031f0ed1ccd73c506743816201dd3f21330ffe69dcd43db SHA512 325697cf37075c313956621707ec9ae40a51ec85dfa65d73ccb8695a0b2d14cff0d62a9a30114b60b0404bd9ba25728bc4c350d3c2a65def6afa4a382883746a
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild
new file mode 100644
index 000000000000..cbeaf43cca12
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}