summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernandez-Alcon, Jose <jose@atlantis.blackmagic.io>2017-10-05 21:13:41 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-11-10 17:23:57 -0500
commitaa51b1ed27295d644e0c2ac2bdd5cb4fa764a793 (patch)
treed27d51667f92b485a7cdad4614c4ef5430bd44d8
parentprofiles: mask sci-geosciences/gmapcatcher (diff)
downloadgentoo-aa51b1ed27295d644e0c2ac2bdd5cb4fa764a793.tar.gz
gentoo-aa51b1ed27295d644e0c2ac2bdd5cb4fa764a793.tar.bz2
gentoo-aa51b1ed27295d644e0c2ac2bdd5cb4fa764a793.zip
app-backup/spideroak-bin: mark 6.4.0 bug #633594
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--app-backup/spideroak-bin/Manifest2
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-6.4.0.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/app-backup/spideroak-bin/Manifest b/app-backup/spideroak-bin/Manifest
index 2c99a817230c..fccbec3f6363 100644
--- a/app-backup/spideroak-bin/Manifest
+++ b/app-backup/spideroak-bin/Manifest
@@ -1,2 +1,4 @@
DIST spideroak-bin-6.3.0_amd64.deb 26863968 SHA256 553aa6fb4d1b5ed105a67adfdd56b817f5236b0a8fe3f278a45f80e74d3ff806 SHA512 d1eadf017a63bf328ae25d3d4bd6d6d7a69b6d04917ae8f1bd913c4276c477effb397d254c94526c81ae8e0f08d6d13ab98d607389d1f3df8fb02b7acb5e0661 WHIRLPOOL bf6101dd6b496dfa3f9c3a2a3addb870a01187545251ef8e2610b22b2f7966177f1170e6d06163c4670aaa6b664af7d64464d2f6a63411c0c2a90c9aad578afe
DIST spideroak-bin-6.3.0_x86.deb 26385528 SHA256 91e83928bf3259f43c8aeea67ec70288b4b56221b1434a7ce9b723f99e5f2b28 SHA512 356b00f730fdbbf6a88a720bd0f546c8dec231c7601c1a8c2a78f085e972ea087b96eb6670ede7e593cf508ed56bda571af65a23560baf0869148d66057bc9bd WHIRLPOOL 81747c30f75f55d5586bd53be068c79b14c2c173fdbf5a5969ad682872e2fbda43a3919662221fb945b1a46fead04dd5eb8dee27c2919aa6dc030b2e2b7b2b98
+DIST spideroak-bin-6.4.0_amd64.deb 26882606 SHA256 a94d4ad3657d7437ee4ef5b7a5feb2687b78dafab45f94c6cb2fb5f246c9dcfe SHA512 23283574955833199cc86be9eec3781c190da8a0885c31b20bfb7f73976c8e3663c76571ddf5f2c9e9d2377d71121f605ce7698788704b482dbce8290e77a7e2 WHIRLPOOL bb01e1af96612d36baa15d9e7ab22c400e702c1b04d9afadab78b8318fa7a47de7524d3d1b50825542f16bd5ee86069f9b50d79a459521e3aebb73284fd80d08
+DIST spideroak-bin-6.4.0_x86.deb 26402134 SHA256 63252488965c5098d0b0a68be6118276a546ca61ae6ef8495d4db820e3a15319 SHA512 3945d671f0dff0e193bf0cd951d2380f50f28921ab3166d26cebf2564caef03e46967c0032b2da02b012ab4c71332af869d117e0ac7c5dfde99dc1e9d9399d5e WHIRLPOOL 1af45020968e4416f85c5dcd619b77a56aea3a13043e529deb7a899e93cf5614a33b959ad1b8424c518905d0f2317b6157a31603ca3cdf4ae866a5d86b570836
diff --git a/app-backup/spideroak-bin/spideroak-bin-6.4.0.ebuild b/app-backup/spideroak-bin/spideroak-bin-6.4.0.ebuild
new file mode 100644
index 000000000000..ee101fd0f537
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-6.4.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils unpacker
+
+DESCRIPTION="Secure free online backup, storage, and sharing system"
+HOMEPAGE="https://spideroak.com"
+
+SRC_URI_BASE="https://spideroak.com/release/spideroak"
+SRC_URI="x86? ( ${SRC_URI_BASE}/deb_x86 -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}/deb_x64 -> ${P}_amd64.deb )"
+
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus X"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ media-libs/libpng:1.2
+ dbus? ( sys-apps/dbus )
+ X? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_prepare() {
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOakONE/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+
+ #Remove the libraries that break compatibility in modern systems
+ #SpiderOak will use the system libs instead
+ rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
+ rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
+ rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
+ rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"
+
+ eapply_user
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOakONE
+
+ # inotify_dir_watcher needs to be marked executable, bug #453266
+ #chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher
+
+ #install the executable
+ exeinto /opt/SpiderOakONE/lib
+ doexe opt/SpiderOakONE/lib/SpiderOakONE
+ doexe opt/SpiderOakONE/lib/inotify_dir_watcher
+ rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOakONE
+ doins -r opt/SpiderOakONE/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOakONE.1.gz
+
+ if use X; then
+ domenu usr/share/applications/SpiderOakONE.desktop
+ doicon usr/share/pixmaps/SpiderOakONE.png
+ fi
+}
+
+pkg_postinst() {
+ if ! use X; then
+ einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}