summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-01-23 21:48:20 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2016-01-23 21:48:20 +0300
commitabeac6ee8e78e99d74c1fea511e8bb208b9f5e58 (patch)
tree66ff8eb301994c83d15cae1d7a5ff3651d72d785
parentprofiles: Unmask xorg-server-1.18, xorg-drivers-1.18 and xf86-input-evdev-2.10.* (diff)
downloadgentoo-abeac6ee8e78e99d74c1fea511e8bb208b9f5e58.tar.gz
gentoo-abeac6ee8e78e99d74c1fea511e8bb208b9f5e58.tar.bz2
gentoo-abeac6ee8e78e99d74c1fea511e8bb208b9f5e58.zip
media-video/mpv: add support for vaapi-drm configure option to 9999
Package-Manager: portage-2.2.27
-rw-r--r--media-video/mpv/mpv-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index b6a029730825..93c6e4f940d1 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -46,7 +46,7 @@ REQUIRED_USE="
opengl? ( X )
uchardet? ( iconv )
v4l? ( || ( alsa oss ) )
- vaapi? ( || ( X wayland ) )
+ vaapi? ( || ( gbm X wayland ) )
vdpau? ( X )
wayland? ( egl )
xinerama? ( X )
@@ -94,7 +94,7 @@ COMMON_DEPEND="
samba? ( net-fs/samba )
sdl? ( media-libs/libsdl2[sound,threads,video,X?,wayland?] )
v4l? ( media-libs/libv4l )
- vaapi? ( >=x11-libs/libva-1.4.0[X?,wayland?] )
+ vaapi? ( >=x11-libs/libva-1.4.0[drm?,X?,wayland?] )
wayland? (
>=dev-libs/wayland-1.6.0
>=x11-libs/libxkbcommon-0.3.0
@@ -239,6 +239,7 @@ src_configure() {
$(use_enable vaapi) # See below for vaapi-x-egl
$(usex vaapi "$(use_enable X vaapi-x11)" '--disable-vaapi-x11')
$(usex vaapi "$(use_enable wayland vaapi-wayland)" '--disable-vaapi-wayland')
+ $(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
$(usex vaapi "$(use_enable opengl vaapi-glx)" '--disable-vaapi-glx')
$(use_enable libcaca caca)
$(use_enable jpeg)