summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-21 13:37:08 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-21 13:37:25 +0100
commitad94bd464b049d72d5f263acb5b71273c0c8f799 (patch)
tree3a263f0033aaa40a28c6be3c0a444f1c189e4cef
parentmedia-sound/fluidsynth: bump to 1.1.9 and update remoteid (diff)
downloadgentoo-ad94bd464b049d72d5f263acb5b71273c0c8f799.tar.gz
gentoo-ad94bd464b049d72d5f263acb5b71273c0c8f799.tar.bz2
gentoo-ad94bd464b049d72d5f263acb5b71273c0c8f799.zip
media-sound/qsynth: bump to 0.5.0
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.5.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index f7f4c221e80d..040188fe2853 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.4.4.tar.gz 260482 BLAKE2B c36e80bbe71960e83ef2bb7a9f0383625b12bb1f3755319218d8144d3a6749a807634b6babd40891f2ad0fca045b2be55dcbe0c60bdcbd150d32177c38046bdd SHA512 8995881ab992b8d02f83797093d406391327a362d0c331d0c8e023e1695baff5acb589be08427a25563f159067a8965c89be114ce74583db98e5a816f73aa9f0
+DIST qsynth-0.5.0.tar.gz 260537 BLAKE2B def589a1cfb76517fa34811fe75a8379043d7e0f9fc661dd456b49414042662c3a3b8f57e2d0de5fae99cbdb60062b12d9b73b93032115648b9a21921766fbeb SHA512 3c7026edfef3115fae8e2167bb961f5e32d886c8d75b3534a3f110d921264cd270953145a4737f9d6660c55fccce81d7306ec0ce4064df6e7226598b52399298
diff --git a/media-sound/qsynth/qsynth-0.5.0.ebuild b/media-sound/qsynth/qsynth-0.5.0.ebuild
new file mode 100644
index 000000000000..d93b19597565
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.5.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic qmake-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug jack alsa pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-sound/fluidsynth[jack?,alsa?,pulseaudio?]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_enable debug) \
+ --with-qt5=$(qt5_get_bindir)/..
+
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install () {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${ED}usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}