summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 17:26:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-24 17:49:02 +0100
commitae81ad70c83432d8869fec63e9052642ec981d3e (patch)
tree54c3716bf003712374449918823c28faab0ceb78
parentgnome-extra/gnome-shell-extension-dash-to-panel: Extension to have a Win/KDE ... (diff)
downloadgentoo-ae81ad70c83432d8869fec63e9052642ec981d3e.tar.gz
gentoo-ae81ad70c83432d8869fec63e9052642ec981d3e.tar.bz2
gentoo-ae81ad70c83432d8869fec63e9052642ec981d3e.zip
kde-misc/colord-kde: EAPI-7 bump, fix HOMEPAGE, various upstream fixes
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-misc/colord-kde/Manifest1
-rw-r--r--kde-misc/colord-kde/colord-kde-0.5.0-r1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-misc/colord-kde/Manifest b/kde-misc/colord-kde/Manifest
index cd71911abb83..77f8d566962e 100644
--- a/kde-misc/colord-kde/Manifest
+++ b/kde-misc/colord-kde/Manifest
@@ -1 +1,2 @@
+DIST colord-kde-0.5.0-patches.tar.xz 9500 BLAKE2B e8f4b2f07b7e17eeaddf1cba94945b47a5485213941d7cce3fb9bd0f67bcef37467541e154dfda8babac22fd46778809e84691cc4bebc2e149888a3927e73da7 SHA512 0f153413bd55c294eef1bbb8ae0af60972cdd68df4fe41c1a6fade34c4fa37d7195766561a9570a712b87c055cb9bbc54a5c2bf725c7776066f8fa91c00563e5
DIST colord-kde-0.5.0.tar.xz 97572 BLAKE2B 7cb5434c25e576c98e2ffbf428bf81d37605fd489199bacc2c040d443021f1f1055b3640f2698b622b021e34f4c517e168a45cd2c1006fdc2c24590789b482e3 SHA512 f285931f0f97462fcf173f64aaf2f32752bddb0b724d2055055ce5beb7dbe89ccebc62cb8c2ce455a8d68beb737fd55bf89be8e4dc7eaa37f09878b757370f07
diff --git a/kde-misc/colord-kde/colord-kde-0.5.0-r1.ebuild b/kde-misc/colord-kde/colord-kde-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..74efceffb01a
--- /dev/null
+++ b/kde-misc/colord-kde/colord-kde-0.5.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Provides interfaces and session daemon to colord"
+HOMEPAGE="https://cgit.kde.org/colord-kde.git"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz
+https://dev.gentoo.org/~asturm/distfiles/${P}-patches.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ media-libs/lcms:2
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwindowsystem)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ x11-misc/colord
+"
+
+PATCHES=( "${WORKDIR}/${P}-patches" )
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ if ! has_version "gnome-extra/gnome-color-manager"; then
+ elog "You may want to install gnome-extra/gnome-color-manager to add support for"
+ elog "colorhug calibration devices."
+ fi
+}