summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-07 15:43:29 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-07 20:39:48 +0000
commitaedade552fd238280d0f29afa6dcbe4c91c1ee26 (patch)
treeede9c8a357b7b888047f7398228fdf280269f466
parentdev-ml/ppx_tools: add ocamlopt useflag, bug #624170 (diff)
downloadgentoo-aedade552fd238280d0f29afa6dcbe4c91c1ee26.tar.gz
gentoo-aedade552fd238280d0f29afa6dcbe4c91c1ee26.tar.bz2
gentoo-aedade552fd238280d0f29afa6dcbe4c91c1ee26.zip
sci-astronomy/casacore: remove buggy old.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--sci-astronomy/casacore/Manifest1
-rw-r--r--sci-astronomy/casacore/casacore-2.1.0.ebuild90
-rw-r--r--sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch45
-rw-r--r--sci-astronomy/casacore/files/casacore-disable-tpath-test.patch49
4 files changed, 0 insertions, 185 deletions
diff --git a/sci-astronomy/casacore/Manifest b/sci-astronomy/casacore/Manifest
index c940c394f98a..bbaac6d36c85 100644
--- a/sci-astronomy/casacore/Manifest
+++ b/sci-astronomy/casacore/Manifest
@@ -1,2 +1 @@
-DIST casacore-2.1.0.tar.gz 10173155 SHA256 9c0017e741c1c4b14bc09582867910f750cd76ff2673e0ecd554aa5b2db7acb4 SHA512 ab52bed9ebc5aef79c7b46c963c90fe9db2e7bac82249f99ed0def2496065ae337cdd9359fb9a6c0182fc3faa702f476116bf0edffc54585a3353a43ce6ddd9f WHIRLPOOL cda1fba87a02d5564a3f56c93eaad2c674bc7f8795d4bd56152549174405cd761ef1df5a00d27ebd0d2bf37fe663b17bbd961508607d1a39e1c494795f6fa755
DIST casacore-2.3.0.tar.gz 10326408 SHA256 d8ed5373f5447885be6d3aac72f26cee24a662df5caf4a6cd23e846b79181700 SHA512 48d09e74b0c3885eb9f7bd048f0fd158397f7c6aa2bf9f713af9dbfcf3ce2c5ba0abb9500d3fe1d32977a35e0941b273fbfd8ee69c991a19df264f5f5a28cbb0 WHIRLPOOL c343a6d419e2e39b888141768abba2c7432e58a8751311e70edd856feb71e4ebcd854ea6e47d72505493bc368d022019178b7dd51c7544f725b332b06f521a00
diff --git a/sci-astronomy/casacore/casacore-2.1.0.ebuild b/sci-astronomy/casacore/casacore-2.1.0.ebuild
deleted file mode 100644
index 064b4da1bc65..000000000000
--- a/sci-astronomy/casacore/casacore-2.1.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# python3 is experimental and only one python is supported
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils eutils toolchain-funcs fortran-2 python-single-r1
-
-DESCRIPTION="Core libraries for the Common Astronomy Software Applications"
-HOMEPAGE="https://github.com/casacore/casacore"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="c++11 +data doc fftw hdf5 openmp python threads test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- sci-astronomy/wcslib:0=
- sci-libs/cfitsio:0=
- sys-libs/readline:0=
- virtual/blas
- virtual/lapack
- data? ( sci-astronomy/casa-data )
- fftw? ( sci-libs/fftw:3.0= )
- hdf5? ( sci-libs/hdf5:0= )
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost:0=[python,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( sci-astronomy/casa-data sci-astronomy/sofa_c )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-disable-tpath-test.patch"
- "${FILESDIR}/${PN}-2.1.0-fix-c++14.patch"
-)
-
-pkg_pretend() {
- if [[ $(tc-getCC)$ == *gcc* ]] && [[ ${MERGE_TYPE} != binary ]]; then
- use c++11 && [[ $(gcc-major-version) -lt 4 ]] || \
- ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) && \
- die "You are using gcc but gcc-4.7 or higher is required for C++11"
- use openmp && ! tc-has-openmp && \
- die "You are using gcc but without OpenMP capabilities that you requested"
- fi
-}
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- fortran-2_pkg_setup
-}
-
-src_configure() {
- has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
- local mycmakeargs=(
- -DENABLE_SHARED=ON
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DDATA_DIR="${EPREFIX}/usr/share/casa/data"
- -DBUILD_PYTHON="$(usex python)"
- -DBUILD_TESTING="$(usex test)"
- -DCXX11="$(usex c++11)"
- -DUSE_FFTW3="$(usex fftw)"
- -DUSE_HDF5="$(usex hdf5)"
- -DUSE_OPENMP="$(usex openmp)"
- -DUSE_THREADS="$(usex threads)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc; then
- doxygen doxygen.cfg || die
- fi
-}
-
-src_install(){
- cmake-utils_src_install
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/html
- fi
-}
diff --git a/sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch b/sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch
deleted file mode 100644
index b14b7035c60c..000000000000
--- a/sci-astronomy/casacore/files/casacore-2.1.0-fix-c++14.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 3a45f84ccb6f08270fd6fd299eaf1b5401199d77 Mon Sep 17 00:00:00 2001
-From: Tammo Jan Dijkema <T.J.Dijkema@gmail.com>
-Date: Fri, 18 Mar 2016 10:43:13 +0100
-Subject: [PATCH] Add std to isinf and isnan, fixes #337
-
----
- casa/BasicMath/Math.cc | 4 ++--
- casa/BasicMath/test/tMathNaN.cc | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/casa/BasicMath/Math.cc b/casa/BasicMath/Math.cc
-index d1bd984..00659e3 100644
---- a/casa/BasicMath/Math.cc
-+++ b/casa/BasicMath/Math.cc
-@@ -178,7 +178,7 @@ Bool isInf(Float val) {
- // infinite. I can only have access to Solaris, Linux and SGI machines to
- // determine this.
- #if defined(AIPS_LINUX)
-- return (isinf(Double(val)));
-+ return (std::isinf(Double(val)));
- #elif defined(AIPS_DARWIN)
- return (std::isinf(Double(val)));
- #elif defined(AIPS_SOLARIS) || defined(AIPS_IRIX)
-@@ -212,7 +212,7 @@ Bool isInf(Double val) {
- // infinite. I can only have access to Solaris, Linux and SGI machines to
- // determine this.
- #if defined(AIPS_LINUX)
-- return (isinf(Double(val)));
-+ return (std::isinf(Double(val)));
- #elif defined(AIPS_DARWIN)
- return (std::isinf(Double(val)));
- #elif defined(AIPS_SOLARIS) || defined(AIPS_IRIX)
-diff --git a/casa/BasicMath/test/tMathNaN.cc b/casa/BasicMath/test/tMathNaN.cc
-index f1a73bc..0c330d1 100644
---- a/casa/BasicMath/test/tMathNaN.cc
-+++ b/casa/BasicMath/test/tMathNaN.cc
-@@ -43,7 +43,7 @@
- ((*(Int *)(x) & 0x007fffff) != 0x00000000))
-
- inline Bool isNaN_isnan(Float val) {
-- return (isnan(Double(val)));
-+ return (std::isnan(Double(val)));
- }
-
- inline Bool isNaN_isnanf(const Float& val) {
diff --git a/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch b/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch
deleted file mode 100644
index e92e1e7ac4f8..000000000000
--- a/sci-astronomy/casacore/files/casacore-disable-tpath-test.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From: Benda Xu <heroxbd@gentoo.org>
-Date: Wed, 29 Oct 2014 16:40:47 +0900
-Subject: disable tPath test
-MIME-Version: 1.0
-Content-Type: text/plain; charset="utf-8"
-Content-Transfer-Encoding: 8bit
-
-Forwarded: no need
-Description: sbuild gets HOME variable leaked into the build environment
- Debian uses sbuild as official build farm. Until the cause is pinned down,
- this test is disabled.
-
- 98/425 Test #101: tPath ...............................***Failed 0.64 sec
-1,16d0
-< expanded: /home/heroxbd
-< expected: /«PKGBUILDDIR»
-< absolute: /home/heroxbd
-< expected: /«PKGBUILDDIR»
-< expanded: /home/heroxbd/test/test2
-< expected: /«PKGBUILDDIR»/test/test2
-< absolute: /home/heroxbd/test/test2
-< expected: /«PKGBUILDDIR»/test/test2
-< expanded: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-< absolute: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-< expanded: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-< absolute: /home/heroxbd/test
-< expected: /«PKGBUILDDIR»/test
-33a18
-> OK
-FAIL (output not verified): ./tPath
----
- casa/OS/test/CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/casa/OS/test/CMakeLists.txt b/casa/OS/test/CMakeLists.txt
-index 4a31f7a..10d5b80 100644
---- a/casa/OS/test/CMakeLists.txt
-+++ b/casa/OS/test/CMakeLists.txt
-@@ -12,7 +12,6 @@ tMemory
- tMemoryTrace
- tModcompConversion
- tMutex
--tPath
- tPrecTimer
- tTime
- tTimer