summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-04-02 19:12:53 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-02 19:15:32 -0700
commitaff9434d4a7acfa830d392ed72af6b43f4608a20 (patch)
tree3491ab7ac376edece7d0b42e1a35c749d1807658
parentsci-libs/scikits-0.1-r2: add python3_8 (diff)
downloadgentoo-aff9434d4a7acfa830d392ed72af6b43f4608a20.tar.gz
gentoo-aff9434d4a7acfa830d392ed72af6b43f4608a20.tar.bz2
gentoo-aff9434d4a7acfa830d392ed72af6b43f4608a20.zip
Move dev-libs/yaml-cpp to dev-cpp/yaml-cpp
Somehow did not see the original package when I searched for it Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-libs/yaml-cpp/Manifest1
-rw-r--r--dev-libs/yaml-cpp/metadata.xml8
-rw-r--r--dev-libs/yaml-cpp/yaml-cpp-0.6.3.ebuild74
-rw-r--r--profiles/updates/2Q-20201
-rw-r--r--sys-cluster/ceph/ceph-15.2.0.ebuild2
5 files changed, 2 insertions, 84 deletions
diff --git a/dev-libs/yaml-cpp/Manifest b/dev-libs/yaml-cpp/Manifest
deleted file mode 100644
index 65c478502e0d..000000000000
--- a/dev-libs/yaml-cpp/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST yaml-cpp-0.6.3.tar.gz 1398768 BLAKE2B 07abe1c56740105a0af2335bb1cd48086cb614d9d04c61342e53788bfb043fd7eb2629e441a0a5be50898b288f3526f1707c5fdf1d734395b6450c3103773b14 SHA512 68b9ce987cabc1dec79382f922de20cc2c222cb9c090ecb93dc686b048da5c917facf4fce6d8f72feea44b61e5a6770ed3b0c199c4cd4e6bde5b6245c09f8e49
diff --git a/dev-libs/yaml-cpp/metadata.xml b/dev-libs/yaml-cpp/metadata.xml
deleted file mode 100644
index 126b9ca42a25..000000000000
--- a/dev-libs/yaml-cpp/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <name>Patrick McLean</name>
- <email>chutzpah@gentoo.org</email>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-libs/yaml-cpp/yaml-cpp-0.6.3.ebuild b/dev-libs/yaml-cpp/yaml-cpp-0.6.3.ebuild
deleted file mode 100644
index 35bba105594c..000000000000
--- a/dev-libs/yaml-cpp/yaml-cpp-0.6.3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1 multibuild cmake-utils
-
-DESCRIPTION="A YAML parser and emitter in C++"
-HOMEPAGE="https://github.com/jbeder/yaml-cpp"
-SRC_URI="https://github.com/jbeder/${PN}/archive/${P}.tar.gz"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="MIT"
-SLOT="0/0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs test"
-
-BDEPEND="
- test? ( ${PYTHON_DEPS} )
-"
-
-RESTRICT="!test? ( test )"
-
-CMAKE_MAKEFILE_GENERATOR=emake
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- MULTIBUILD_VARIANTS=(shared)
- use static-libs && MULTIBUILD_VARIANTS+=(static)
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- multibuild_foreach_variant yaml-cpp_configure
-}
-
-yaml-cpp_configure() {
- local -a mycmakeargs=(
- -DYAML_BUILD_SHARED_LIBS=$(
- if [[ ${MULTIBUILD_VARIANT} == shared ]]; then
- printf 'ON\n'
- else
- printf 'OFF\n'
- fi
- )
- -DYAML_CPP_BUILD_TESTS=$(usex test)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- multibuild_foreach_variant cmake-utils_src_compile
-}
-
-src_test() {
- multibuild_foreach_variant yaml-cpp_test
-}
-
-yaml-cpp_test() {
- pushd "${BUILD_DIR}" >/dev/null || die
- pwd
- ./test/run-tests || die "tests failed for ${MULTIBUILD_VARIANT} libs"
- popd >/dev/null || die
-}
-
-src_install() {
- multibuild_foreach_variant cmake-utils_src_install
-}
diff --git a/profiles/updates/2Q-2020 b/profiles/updates/2Q-2020
new file mode 100644
index 000000000000..a56d939ff3e3
--- /dev/null
+++ b/profiles/updates/2Q-2020
@@ -0,0 +1 @@
+move dev-libs/yaml-cpp dev-cpp/yaml-cpp
diff --git a/sys-cluster/ceph/ceph-15.2.0.ebuild b/sys-cluster/ceph/ceph-15.2.0.ebuild
index 67e9df32dd59..d3c354015a03 100644
--- a/sys-cluster/ceph/ceph-15.2.0.ebuild
+++ b/sys-cluster/ceph/ceph-15.2.0.ebuild
@@ -49,7 +49,7 @@ COMMON_DEPEND="
dev-libs/libnl:3=[static-libs?]
dev-libs/libxml2:=[static-libs?]
dev-libs/xmlsec:=[!openssl?,!libressl?,static-libs?]
- dev-libs/yaml-cpp:=[static-libs?]
+ dev-cpp/yaml-cpp:=[static-libs?]
dev-libs/nss:=
dev-libs/protobuf:=[static-libs?]
net-dns/c-ares:=[static-libs?]