summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-09-10 13:24:11 +0200
committerWolfram Schlich <wschlich@gentoo.org>2016-09-10 13:24:50 +0200
commitb073447f376f7692c550f5c07a06987c9460775b (patch)
treee8cc713306dfdb064704962247430e9e6e0a3e6e
parentdev-perl/XML-Parser: fix get_libdir in global scope, bug #593370 (diff)
downloadgentoo-b073447f376f7692c550f5c07a06987c9460775b.tar.gz
gentoo-b073447f376f7692c550f5c07a06987c9460775b.tar.bz2
gentoo-b073447f376f7692c550f5c07a06987c9460775b.zip
media-gfx/displaycal: version bump
Package-Manager: portage-2.2.28
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.1.6.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index c73273156a00..463325fae987 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1,2 +1,3 @@
DIST DisplayCAL-3.1.2.0.tar.gz 9361108 SHA256 78dbfd2be1cf7542657cc0f5ed9e16e27558206a4878ffae5ce68bd62460680d SHA512 2c14ed0230e6bdd6f8876a5e8887498e3005941e2f68aedad2926f9b8dda642e909f9aa70205977123b1b7c1376dd3f361ad08ecc5015bfae77342ff1b848837 WHIRLPOOL 74f311618190974e6e9c0c5b895ab7f0dba18de06e52dcf1cca4df0373a278b4c4e170b6add51bdf550b21499ff1ecf249cae6f2eb2f3e0813c666bd0bc4f941
DIST DisplayCAL-3.1.3.1.tar.gz 9555280 SHA256 d48e0b12c0b4fe75e0c99eb5fd85c8651afc2c3a2e72d29ade9bb0a76e61f645 SHA512 ef560155cf0eebf4fcd9beab699afd6f0e766901e44d6aba8f33242662aae68a5644e6e253f3bdfe2bb687b30e967190ddf746ef4467c41c9cda06c6bd9326ef WHIRLPOOL b696c68d7b25388b51c056534ca37f7e14d0f918b2471cd1e6662cfadc186eb989ad9429c3a40bc74992c9352d762c40e05add69773a834e99971ac46339f015
+DIST DisplayCAL-3.1.6.0.tar.gz 9592426 SHA256 fc27814cf29b3643f8a44973f2139518c133f6a2549ffe51658e765a67cd02fd SHA512 ea5d0c5028c9dcfc834c03bd50d9e4cd5f4528ac0adf1312117128f8969533f857eaab738019d561b8197ad595ca73ad085db4feb36101df1e303933e1edbd87 WHIRLPOOL 6a23f57e606852838b43834d81acd346be1746040d47ac5884c997d828130ddf5b2049b8684d2de42b555ab7b6b6fb4d0430544d2586ca388eb769fbecc86be6
diff --git a/media-gfx/displaycal/displaycal-3.1.6.0.ebuild b/media-gfx/displaycal/displaycal-3.1.6.0.ebuild
new file mode 100644
index 000000000000..0d69de973612
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.1.6.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/DisplayCAL" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+ # Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ # Remove x-world Media Type
+ cd "${S}/misc" || die "Cannot cd to misc directory."
+ sed -e 's/x\-world\/x\-vrml\;//g' -i "displaycal-vrml-to-x3d-converter.desktop" \
+ || die "removing x-world media type failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}