summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-17 13:52:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-17 13:52:19 +0100
commitb1bb6e39a6b49e61698be3175983c7326193eaef (patch)
treeae4d9d6a61ade416db80d78aaa9669c91728b569
parentmedia-sound/hydrogen: EAPI-7 bump (diff)
downloadgentoo-b1bb6e39a6b49e61698be3175983c7326193eaef.tar.gz
gentoo-b1bb6e39a6b49e61698be3175983c7326193eaef.tar.bz2
gentoo-b1bb6e39a6b49e61698be3175983c7326193eaef.zip
sys-apps/texinfo: Bump to version 6.6
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-6.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 58915890367a..cb108ee5e26a 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -2,3 +2,4 @@ DIST texinfo-6.1.tar.xz 4520376 BLAKE2B 3b96ed431288815df4261fcd0266f2be01d27f82
DIST texinfo-6.3.tar.xz 4468048 BLAKE2B ef255225e1f66dc5e6646761d78dcf3e7ba9c79aa2654dbb527ef10db54b8417af9e1a58a270683956624049c2fb624b29bc2f22763c79bab9858cdcf5e2edce SHA512 ef6c5878d9db497d7963bd9138418b30c39a5605c215bf2f4e8f1f083d93c3c99f8c459aa675f7da3b78da6189cb6bbf3cf19a2ee1d52e569de2f6ce82762bf4
DIST texinfo-6.4.tar.xz 4497624 BLAKE2B 7081131868f748036c39812674fa8b962144fe6b96445ff72b5a88537a9a044c45cab33bfaf0d3169c0bfb6ce60832c908e49a04ef04d7631ba345002b552f92 SHA512 628e7fb64c4cb6d4ec879d5593e3660dbbbf41915c7aec68b6af209a1c496bee8a3879a69e4e047c3bee0cb476540ffd6ebdef5ec7b712edd191a82ce9ac4006
DIST texinfo-6.5.tar.xz 4503048 BLAKE2B 9e194115a252500fe6048614a96c6992b6fbf9f3557265d8bdda143e10f781769ca5e97ded2d330da7c0ae1581bfdebbf2dbde736689412980b098ea935d9580 SHA512 06831b4c74a1ba7a9cff937069e40ab26db1204aa8761d63254651ffacf6b0cb95d7078ba1cc59d95427239ab7e4f4aedf582967854281bfea3850b1ed5b1fdc
+DIST texinfo-6.6.tar.xz 4946900 BLAKE2B bd33297549d5285d7a4a65041b6025c489c6b436e9591eaf5187ef34f6e869bf7a2a82a00ebe11adc1c4b2904119e9e3f25d2496b5507f91f4b9ba548ba98604 SHA512 96e0764d0808152d3662e65c3287fb0f86ed918912cdc036380637dbadaacd6a489b516543c07b08105686575e8d495a945f73e23ff0909d5a0f12026e4131e0
diff --git a/sys-apps/texinfo/texinfo-6.6.ebuild b/sys-apps/texinfo/texinfo-6.6.ebuild
new file mode 100644
index 000000000000..41f0f7dd61c7
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-6.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:0=
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Unicode-EastAsianWidth
+ dev-perl/Text-Unidecode
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( >=sys-devel/gettext-0.19.6 )"
+
+src_configure() {
+ use static && append-ldflags -static
+ local myeconfargs=(
+ --with-external-libintl-perl
+ --with-external-Unicode-EastAsianWidth
+ --with-external-Text-Unidecode
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}