summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-31 18:55:53 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-31 18:57:07 +0800
commitb2792043133dbf76bcdfdc84e4bcfadffeb8a1ca (patch)
tree97d86c18adf20b4e8ff5b2dcbbdd8f3ce8b1af63
parentmedia-libs/tiff: Bump to version 4.0.5 (diff)
downloadgentoo-b2792043133dbf76bcdfdc84e4bcfadffeb8a1ca.tar.gz
gentoo-b2792043133dbf76bcdfdc84e4bcfadffeb8a1ca.tar.bz2
gentoo-b2792043133dbf76bcdfdc84e4bcfadffeb8a1ca.zip
dev-python/setproctitle: bump; virtual rewrite
repalce test phase to exclude pypy which the tests are not written to cater to, make a html file of the README for DOCS at install Package-Manager: portage-2.2.20
-rw-r--r--dev-python/setproctitle/Manifest1
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.9.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/setproctitle/Manifest b/dev-python/setproctitle/Manifest
index dc79bcb9f0df..0312da74c848 100644
--- a/dev-python/setproctitle/Manifest
+++ b/dev-python/setproctitle/Manifest
@@ -1 +1,2 @@
DIST setproctitle-1.1.8.tar.gz 23208 SHA256 b564cf6488217c7a4632a9fe646fc3a3bea2f9712b4e667e9632b870d1a58211 SHA512 9d0ab8e65afd7e1ac019ea47995498dae1f82d8aebb333dfc4c953e745441cb9a8db942ad8417522d1f9a805bc50ad680f3a37cb4cbbd4214d261d4fed600b20 WHIRLPOOL 4014739eab6ba3d91a15e2c11d9e91ee6a0254a23be1c2f8a7963bc327559a5a7c6197398d6053743a9479562e76873fe47f11a6c810f2c21d3e462440183166
+DIST setproctitle-1.1.9.tar.gz 23576 SHA256 1c3414d18f9cacdab78b0ffd8e886d56ad45f22e55001a72aaa0b2aeb56a0ad7 SHA512 f5640543105dd039192378983b098e0eca643b5eee314a18886aef0d13674e1ea74f753bfb33582f51a6fb34f9c3d0831764bc099dec9b9e14fe12e7446d30f1 WHIRLPOOL d063a443c42eaf9acf02e0e953b0b8ce080418978236700de1a23d7f234f562ae36ec3d8a965e4fd184f1d03491cc7ca159bbdf12886b7cd3e45e3f98d8db486
diff --git a/dev-python/setproctitle/setproctitle-1.1.9.ebuild b/dev-python/setproctitle/setproctitle-1.1.9.ebuild
new file mode 100644
index 000000000000..a3eda2130d10
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# pypy doesn't get started in test run. Still required by www-servers/gunicorn
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="https://code.google.com/p/py-setproctitle/ https://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos \
+ ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# Required for re-write of test suite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # Make a nice html file
+ rst2html.py README.rst > README.html
+ # The README.rst will be duplicated in src_install
+ rm README.rst || die
+}
+
+python_test() {
+ # The suite via the Makefile appears to not cater to pypy
+ if [[ "${EPYTHON}" != pypy ]]; then
+ emake check
+ fi
+}