summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-03-26 00:34:31 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-03-26 00:34:31 +0000
commitb36fc6b1bac11514331a32c8bafc0338f0f8bb81 (patch)
tree9b1ca25c510f2933ea2883ec63cc4171948ec5f7
parent2022-03-26 00:19:45 UTC (diff)
parentecm.eclass: provides virtualx.eclass (diff)
downloadgentoo-b36fc6b1bac11514331a32c8bafc0338f0f8bb81.tar.gz
gentoo-b36fc6b1bac11514331a32c8bafc0338f0f8bb81.tar.bz2
gentoo-b36fc6b1bac11514331a32c8bafc0338f0f8bb81.zip
Merge updates from master
-rw-r--r--dev-util/rocminfo/rocminfo-5.0.2.ebuild3
-rw-r--r--eclass/ecm.eclass2
-rw-r--r--media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild (renamed from media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1.ebuild)18
-rw-r--r--media-sound/gnome-music/Manifest1
-rw-r--r--media-sound/gnome-music/gnome-music-42.0.ebuild74
-rw-r--r--media-sound/gnome-sound-recorder/Manifest1
-rw-r--r--media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild50
-rw-r--r--media-video/totem/Manifest1
-rw-r--r--media-video/totem/totem-42.0.ebuild121
-rw-r--r--net-misc/gnome-remote-desktop/Manifest1
-rw-r--r--net-misc/gnome-remote-desktop/gnome-remote-desktop-42.0.ebuild64
-rw-r--r--sci-geosciences/gpsprune-bin/gpsprune-bin-20.4.ebuild8
-rw-r--r--sci-geosciences/viking/viking-1.10.ebuild5
-rw-r--r--sys-apps/restartd/restartd-0.2.2-r1.ebuild4
-rw-r--r--www-client/w3mmee/w3mmee-0.3.2_p24-r12.ebuild8
15 files changed, 332 insertions, 29 deletions
diff --git a/dev-util/rocminfo/rocminfo-5.0.2.ebuild b/dev-util/rocminfo/rocminfo-5.0.2.ebuild
index 51039d18e84d..1cbe2856e43a 100644
--- a/dev-util/rocminfo/rocminfo-5.0.2.ebuild
+++ b/dev-util/rocminfo/rocminfo-5.0.2.ebuild
@@ -24,8 +24,7 @@ DEPEND="${RDEPEND}"
PATCHES=("${FILESDIR}/${PN}-4.3.0-detect-builtin-amdgpu.patch")
-src_prepare()
-{
+src_prepare() {
sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
cmake_src_prepare
}
diff --git a/eclass/ecm.eclass b/eclass/ecm.eclass
index 8c5e8bab1b4d..3cc586b82d82 100644
--- a/eclass/ecm.eclass
+++ b/eclass/ecm.eclass
@@ -5,7 +5,7 @@
# @MAINTAINER:
# kde@gentoo.org
# @SUPPORTED_EAPIS: 7 8
-# @PROVIDES: cmake
+# @PROVIDES: cmake virtualx
# @BLURB: Support eclass for packages that use KDE Frameworks with ECM.
# @DESCRIPTION:
# This eclass is intended to streamline the creation of ebuilds for packages
diff --git a/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1.ebuild b/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild
index a6586dda664b..bf44773fcf29 100644
--- a/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1.ebuild
+++ b/media-libs/nv-codec-headers/nv-codec-headers-11.1.5.1-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit multilib-minimal
-
DESCRIPTION="FFmpeg version of headers required to interface with Nvidias codec APIs"
HOMEPAGE="https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git"
SRC_URI="https://github.com/FFmpeg/nv-codec-headers/releases/download/n${PV}/${P}.tar.gz"
@@ -13,17 +11,13 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
-RDEPEND=">=x11-drivers/nvidia-drivers-470.57.02[${MULTILIB_USEDEP}]"
-
-src_prepare() {
- default
- multilib_copy_sources
-}
-
-multilib_src_compile() {
+src_compile() {
emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)"
}
-multilib_src_install() {
- emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)" DESTDIR="${D}" install
+src_install() {
+ emake PREFIX="${EPREFIX}"/usr LIBDIR="$(get_libdir)" DESTDIR="${ED}" install
+
+ mkdir -p "${ED}"/usr/share || die
+ mv "${ED}/usr/$(get_libdir)/pkgconfig" "${ED}"/usr/share/ || die
}
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 41d6af8d7f3c..0a039e9885ea 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1 +1,2 @@
DIST gnome-music-41.0.tar.xz 898652 BLAKE2B cc72eb7be553ccefe10620a85aa3ee75aa30c1809e810a8ebb30a2ffbccebb9dc173cc79859e098be97fea9c964f0f6969f55c7c84ea9540a93a920376746ac1 SHA512 883f8862d5216ab30c3208a316378c2ef016ba52861c9261b8fa9ceb44f935e4dc35608ea66b333c3bf61c9dcc950fa338adfadc2d5e7f67a7a84467228d28a2
+DIST gnome-music-42.0.tar.xz 1651960 BLAKE2B 43ecee648441dab0b562e5a307554e62b3aac5f55f798bbcdbf99c50fd034b5fe52f9fafcac95a0e12e910499618337e37042ca7482e313b3854ed708f4f4cde SHA512 2e104188681337d200fabdfb2a332e4c01c8c0357580fc6f8c53fa0e44ebc4785c33acf0b32f201cad0acdfc0cb4a6dcf21b15842d0aa0b480add5f91d2a46e7
diff --git a/media-sound/gnome-music/gnome-music-42.0.ebuild b/media-sound/gnome-music/gnome-music-42.0.ebuild
new file mode 100644
index 000000000000..1ca03facd942
--- /dev/null
+++ b/media-sound/gnome-music/gnome-music-42.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music https://gitlab.gnome.org/GNOME/gnome-music/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.67.1:2
+ >=net-libs/gnome-online-accounts-3.35.90[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=gui-libs/gtk-4.5.0:4[introspection]
+ >=gui-libs/libadwaita-1.0:1=[introspection]
+ >=media-libs/libmediaart-1.9.1:2.0[introspection]
+ net-libs/libsoup:2.4[introspection]
+ app-misc/tracker:3=[introspection(+)]
+ >=x11-libs/pango-1.44:=
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
+ ')
+ >=media-libs/grilo-0.3.13:0.3[introspection]
+ >=media-plugins/grilo-plugins-0.3.13:0.3
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+ || (
+ app-misc/tracker-miners:3[gstreamer]
+ app-misc/tracker-miners:3[ffmpeg]
+ )
+ x11-libs/libnotify[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/grilo-plugins:0.3[tracker]
+ x11-misc/xdg-user-dirs
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gnome-music
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/media-sound/gnome-sound-recorder/Manifest b/media-sound/gnome-sound-recorder/Manifest
index b9e486b7019b..d86cb48908d8 100644
--- a/media-sound/gnome-sound-recorder/Manifest
+++ b/media-sound/gnome-sound-recorder/Manifest
@@ -1 +1,2 @@
DIST gnome-sound-recorder-40.0.tar.xz 199056 BLAKE2B e830b746ccf9e038a6f425dee9a6ef8eb88cd849659570c11364b833b0be8c7e7302c0b20e8c853d7228a589d6e3953fecf2fddb31304a1905678aa99b461248 SHA512 28de1dbb9251c834513be55c3f4107cd014d74e634e383e6feb3b9430ff562e19d29e9abcd566b0fc0ed1ec3841add0f694b47c51fe91a3b4ba33b9f43a0d617
+DIST gnome-sound-recorder-42.0.tar.xz 162208 BLAKE2B 6f4f17ad5cb2cd893626defb3b91e62c0dfbfdae4c815df934a2d35a7b0e315f689f3ea222d9adef960935828095c337e00076aba60b4c1b3d243c274063aed3 SHA512 53fe2fe0646c5055cedc1c62cf87176dca52bf3d9452d83bcc849d9946179afbef826f08ff65a97ede7a0d14ade4da0755b2ef3780460d5a80f8f9e6c85fcfbd
diff --git a/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild b/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild
new file mode 100644
index 000000000000..e125245f0098
--- /dev/null
+++ b/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Simple sound recorder"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/SoundRecorder https://gitlab.gnome.org/GNOME/gnome-sound-recorder"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/gjs-1.54.0
+ >=dev-libs/glib-2.46:2
+ >=gui-libs/gtk-4.4.0:4[introspection]
+ media-libs/gst-plugins-bad:1.0
+ >=gui-libs/libadwaita-1.1.0:1=
+ >=dev-libs/gobject-introspection-1.31.6
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection,ogg]
+ x11-libs/gdk-pixbuf:2[introspection]
+"
+RDEPEND="${DEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-flac:1.0
+ media-plugins/gst-plugins-pulse:1.0
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/media-video/totem/Manifest b/media-video/totem/Manifest
index 537bbeac0ce6..9e11ac415eca 100644
--- a/media-video/totem/Manifest
+++ b/media-video/totem/Manifest
@@ -1 +1,2 @@
DIST totem-3.38.2.tar.xz 2190700 BLAKE2B 3b3b8166cf674b882a3a66a5729d794489fe779944bb277fad35fe027b56270e6ef578590924309b9fe28aca0544754696acd98d31a7243a33a533abe73ed6fd SHA512 1dac3a0afe31b47147a129c70dddf7480446fc1bb5432f9cd537384e3be25da6a9b87918fa7bcf7e7cd68c8dac45e75f6b1f7c1885edefac846c52f96b40567f
+DIST totem-42.0.tar.xz 2476952 BLAKE2B 45eac2e586c3c17eab9f570812ae2c79812859635d1ef6df1d0d2c526436558dbab9581699ce86d3e2cd3048f5d65bbd1927c3faa5f7575a5468d0813ce68bcc SHA512 67872d06a7d691a23b97255c5ee5f8d90a1fdf2b36f064f26c10fb4958733772eea456aab4f0fe2c89d23ec987cf5b9c2383c97ba5bec45247953296f1cd6c4b
diff --git a/media-video/totem/totem-42.0.ebuild b/media-video/totem/totem-42.0.ebuild
new file mode 100644
index 000000000000..66b603f2b2ad
--- /dev/null
+++ b/media-video/totem/totem-42.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome.org gnome2-utils meson virtualx xdg python-single-r1
+
+DESCRIPTION="Media player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Videos https://gitlab.gnome.org/GNOME/totem/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="gtk-doc +python test"
+# see bug #359379
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/libhandy-1.5.0:1
+ >=media-libs/gstreamer-1.6.0:1.0
+ >=media-libs/gst-plugins-base-1.6.0:1.0[pango]
+ >=media-libs/gst-plugins-good-1.6.0:1.0
+ >=media-libs/grilo-0.3.0:0.3[playlist]
+ >=dev-libs/libpeas-1.1.0[gtk]
+ >=dev-libs/totem-pl-parser-3.26.5:0=[introspection]
+ gnome-base/gnome-desktop:3=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=dev-libs/gobject-introspection-1.54:=
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ media-plugins/grilo-plugins:0.3
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ x11-themes/adwaita-icon-theme
+ python? (
+ x11-libs/pango[introspection]
+ >=dev-libs/libpeas-1.1.0[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
+BDEPEND="
+ dev-lang/perl
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.5 )
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+# perl for pod2man
+# Prevent dev-python/pylint dep, bug #482538
+
+PATCHES=(
+ "${FILESDIR}"/3.38.0-gst-inspect-sandbox.patch # Allow disabling calls to gst-inspect (sandbox issue)
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ # Drop pointless samplepython plugin from build
+ sed -e '/samplepython/d' -i src/plugins/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Denable-easy-codec-installation=yes
+ -Denable-python=$(usex python yes no)
+ -Dwith-plugins=all # in 3.34.1 only builtin and python plugins are left, and python is extra controlled by enable-python
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dgst-inspect=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0= # bug 812170
+ meson_src_install
+ if use python ; then
+ python_optimize "${ED}"/usr/$(get_libdir)/totem/plugins/
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+src_test() {
+ virtx meson_src_test
+}
diff --git a/net-misc/gnome-remote-desktop/Manifest b/net-misc/gnome-remote-desktop/Manifest
index ac3235876cad..45208c1f2158 100644
--- a/net-misc/gnome-remote-desktop/Manifest
+++ b/net-misc/gnome-remote-desktop/Manifest
@@ -1 +1,2 @@
DIST gnome-remote-desktop-41.2.tar.xz 111000 BLAKE2B 1d6dfcc9860a5253cfb2a8111c5c039e7d236f45fa79a74ddc479f449b01ddb231368c4b604d28a8f796ab33f1648a332e110fd2adb9b739032dba67c029b9f8 SHA512 7636c0446c86748ce51c869734a2d33d8285c30616a28a0358f45d8399fd9f5dba7a1bdb830d3ca4753982ac3b9715604eb5934906645a1c11c58b4342c524eb
+DIST gnome-remote-desktop-42.0.tar.xz 158448 BLAKE2B 35c5458ec314d7e3abc60583d136e18296609af2caac658cf936685085b6f8b6725bc453336131293dadd1b548d110a4cf5cf8871fcb80d838212e60e204feb1 SHA512 3bf03fc96205df4c5efcef0e340ad85e7011ad8e4fecf2e29d9902fbb1633801da7d1094645e850267249dda9383ae0aa782f3e0207a7351d764482f2d0dc349
diff --git a/net-misc/gnome-remote-desktop/gnome-remote-desktop-42.0.ebuild b/net-misc/gnome-remote-desktop/gnome-remote-desktop-42.0.ebuild
new file mode 100644
index 000000000000..e0ed71da320e
--- /dev/null
+++ b/net-misc/gnome-remote-desktop/gnome-remote-desktop-42.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 systemd xdg
+
+DESCRIPTION="Remote desktop daemon for GNOME using pipewire"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-remote-desktop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+rdp systemd +vnc"
+REQUIRED_USE="|| ( rdp vnc )"
+RESTRICT="test" # Tests run xvfb-run directly
+
+DEPEND="
+ x11-libs/cairo
+ >=dev-libs/glib-2.68:2
+ >=media-video/pipewire-0.3.0:=
+ app-crypt/libsecret
+ x11-libs/libnotify
+ media-libs/libepoxy
+ x11-libs/libdrm
+ rdp? (
+ >=media-libs/nv-codec-headers-11.1.5.0
+ >=net-misc/freerdp-2.5.0:=[server]
+ >=sys-fs/fuse-3.9.1
+ >=x11-libs/libxkbcommon-1.0.0
+ )
+ vnc? (
+ net-libs/libvncserver
+ )
+"
+RDEPEND="${DEPEND}
+ x11-wm/mutter[screencast]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use rdp)
+ $(meson_use vnc)
+ $(meson_use systemd)
+ -Dsystemd_user_unit_dir="$(systemd_get_userunitdir)"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/sci-geosciences/gpsprune-bin/gpsprune-bin-20.4.ebuild b/sci-geosciences/gpsprune-bin/gpsprune-bin-20.4.ebuild
index 1babb34afde6..718e125a8c57 100644
--- a/sci-geosciences/gpsprune-bin/gpsprune-bin-20.4.ebuild
+++ b/sci-geosciences/gpsprune-bin/gpsprune-bin-20.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,8 +22,7 @@ gpsprune_desktop="${WORKDIR}/gpsprune.desktop"
S="${WORKDIR}"
-src_prepare()
-{
+src_prepare() {
default
# Provide the necessary files
@@ -51,8 +50,7 @@ src_prepare()
EOF
}
-src_install()
-{
+src_install() {
insinto /opt/gpsprune
doins "gpsprune_${PV}.jar"
exeinto /usr/bin
diff --git a/sci-geosciences/viking/viking-1.10.ebuild b/sci-geosciences/viking/viking-1.10.ebuild
index 131abba15633..3cfec0761b38 100644
--- a/sci-geosciences/viking/viking-1.10.ebuild
+++ b/sci-geosciences/viking/viking-1.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -49,8 +49,7 @@ DEPEND="${COMMONDEPEND}
S="${WORKDIR}/${PN}-${P}"
-src_prepare()
-{
+src_prepare() {
default
eautoreconf
diff --git a/sys-apps/restartd/restartd-0.2.2-r1.ebuild b/sys-apps/restartd/restartd-0.2.2-r1.ebuild
index 6f78d10eb3a3..63a0de4222ca 100644
--- a/sys-apps/restartd/restartd-0.2.2-r1.ebuild
+++ b/sys-apps/restartd/restartd-0.2.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,7 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC) C_ARGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" C_ARGS="${CFLAGS}"
}
src_install() {
diff --git a/www-client/w3mmee/w3mmee-0.3.2_p24-r12.ebuild b/www-client/w3mmee/w3mmee-0.3.2_p24-r12.ebuild
index df4f61d15531..2a9701002838 100644
--- a/www-client/w3mmee/w3mmee-0.3.2_p24-r12.ebuild
+++ b/www-client/w3mmee/w3mmee-0.3.2_p24-r12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -48,8 +48,8 @@ HTML_DOCS=( 00INCOMPATIBLE.html )
src_prepare() {
default
- sed -i "s:/lib\([^a-z$]\):/$(get_libdir)\1:g" configure
- sed -i "/^AR=/s:ar:$(tc-getAR):" XMakefile
+ sed -i "s:/lib\([^a-z$]\):/$(get_libdir)\1:g" configure || die
+ sed -i "/^AR=/s:ar:$(tc-getAR):" XMakefile || die
}
src_configure() {
@@ -86,7 +86,7 @@ src_configure() {
accept_lang=en
EOF
- env CC=$(tc-getCC) "${myuse[@]}" ./configure \
+ env CC="$(tc-getCC)" "${myuse[@]}" ./configure \
-nonstop \
-prefix="${EPREFIX}/usr" \
-suffix=mee \